Fail to install a working mongodb-community@5.0

I’m working on macOS and I tried to install mongodb-community@5.0. No error was reported during the install with brew (I followed this or when I started mongodb-community@5.0. However, the mongodb file was empty and when I listed brew services, the database appeared with an error status 19968. It is impossible to use this version. Oddly, this version was installed by the user “root”, which I think might be problematic.
I tried every possible solution from Stack Overflow,… with no luck.

To move on, I tried to install the lastest version of mongodb-community (the 7.0). The install was successful and the mongodb-community starts properly. This time, while I followed the same steps, the user indicated for this service is mine and not root. For the moment, I can work with this version but I will need to downgrade to 5.0. Do you have any idea why the install is failing? Do you know a way to install the 5.0 while specifying which user should install? Or do you have a sure way to downgrade from 7.0 to 5.0 without any errors ?

Thanks for the help !