Error on mongorestore (AtlasError) parameter changeStreamPreAndPostImages is disallowed in create command

So I was using mongodump and mogorestore to clone one database into another project, the mongodump work fine but when trying to sun the command mongorestore I get the following error:

 Failed: <database>.<collection>: error creating collection <database>.<collection>: error running create command: (AtlasError) parameter changeStreamPreAndPostImages is disallowed in create command

I have try to search for this error but havent found anyone talking about it

Both mongorestore and mongodump are with versions 100.7.0 and both clusters are in version 6.0.6.

I have already done this a couple of times with no problems, suddenly it appeared and not sure why

Hi @Angel_Trevino - Welcome to the community

Can you advise the following:

  1. The full mongorestore and mongodump commands used (redact any personal or sensitive information)
  2. Cluster tier you’re restoring to
  3. The last time you were able to successfully mongorestore using the same command (approximately).


1 Like

Hi @Jason_Tran thank you for the welcoming message.

These where the following commands that I executed.

mongodump --uri <uri source cluster>/<database>
mongorestore --uri <uri destination cluster>

Both clusters are in different projects but they are the shared tiers.

The last time I perform this was like 2-3 weeks ago aprox.

I also tried to do it in another system, and it produce the same error. The systems I did it with were with Windows and MacOS

Not sure if its anything with my configuration or what tbh

1 Like

Thanks for providing those details @Angel_Trevino,

Are you able to confirm if:

  1. The SOURCE cluster where the mongodump is being performed against has triggers associated with it?
  2. If so, is either Full Document or Document Preimage enabled? (Please advise if one or the other or both)
  3. And if yes to 1., is <database>.<collection> (which you mentioned initially, I presume you redacted these details) associated / linked with the trigger?


1 Like

Hello @Jason_Tran thank you for your response,

Neither do the Source or the destination have any triggers register to them.

1 Like

Not sure if this is helpful for debugging the issue but I managed to make my copy by using mongoexport and mongoimport, the only issue is that I had to run the command for each collection I had.

1 Like

Just updating this post - This was behaviour was identified as bug and was fixed several weeks ago.