Hello everyone in loading mongo_dart: ^ 0.7.0 + 2 and sevr: ^ 0.7.0 + 2 on Flutter/Dart.
I have the following error, can someone please help me about to solve it:
flutter pub get
Running “flutter pub get” in app
Because no versions of dio match >4.0.0 <5.0.0 and dio 4.0.0 depends on http_parser ^4.0.0, dio ^4.0.0 requires http_parser ^4.0.0.
And because every version of sevr depends on body_parser ^1.1.1 which depends on http_parser ^3.1.1, dio ^4.0.0 is incompatible with sevr.
So, because catering depends on both dio ^4.0.0 and sevr ^1.0.4, version solving failed.
pub get failed (1; So, because catering depends on both dio ^4.0.0 and sevr ^1.0.4, version solving failed.)
exit code 1