Error MongoDB Atlas SQL Connector in Power BI - field not showing

From some of our collections we have created views that users get access to via the MongoDB Atlas SQL connector in Power BI.
From there they can e.g. create project specific dashboards directly from our mongodb databases.

We thought we had created a good workflow, until I suddenly got a message that a field (mongodb) / column (powerbi) was missing. I checked in atlas and the field was indeed there (it is called customAttributeData).
The user havent had any problems with this before and the same field have been visible in several other power bi files.

I changed the column profiling in power bi to to go through the whole dataset (not just the first 1000 rows as is default)
I thought maybe there were too many fields (around 40 fields) so i changed the view to only include some of the fields
I even tried to create the view where in the end there were 223 rows/documents, 154 which had the field customAttributeData, in case power BI did not read all the columns if many of the documents did not have the field.

I thought maybe it did not show because it was a nested object, but we have indeed other nested objects that are shown in a separate columns in Power BI.

I deleted the cache in power bi, started power bi over and over again, refreshed and refreshed and also connected several times through the Atlas SQL Connector.

Finally, after trying a lot of different stuff, I created the same view with a new name and suddenly the attribute showed up (but i also tried that previously, so i’m not sure why it suddenly worked now)

I’m not sure if the error is because of power bi or mongodb/atlas sql connector

It worked out in the end for now, but it is not great if it’s this unstable.

Has anybody experienced this or know why its happening and how we can avoid it? I Hope anybody can help me make sense of any of this since it does not make any logical sense to me! :slight_smile:

Thank you,

Kind regards Ragnhild

image