Error from mongo db when deploying heroku app

Error is: Couldn’t find either the add-on service or the add-on plan of “mongolab:sandbox”

App is: https://github.com/nightscout/cgm-remote-monitor
App has you configure a bunch of variables, I believe I have them all set correctly and have tried a number of times. But I am wondering the meaning of this error, I am using a free shared plan on mongodb. Thanks

Welcome to the MongoDB Community Forums @Global_Spectrum_Response !

Can you share a link to the Nightscout set up tutorial you are following? The reference to mLab (formerly known as MongoLab) is several years out of date: the mLab Heroku Add-on was discontinued in Nov, 2020 and all mLab accounts have since been migrated to MongoDB Atlas. The Atlas free tier is analogous to the former mLab sandbox.

The guide for New Nightscout Users should have all of the set up steps to follow including setting up an Atlas account, database user, and IP access list. It sounds like you may already be past the Atlas set up stage but there is something referencing the older (and no longer required) mLab Heroku add-on.

Regards,
Stennie

First of all, I’m a non-developer. I found this article while looking for my problem.

I was using the Discord Bot service through the Heroku button. It originally worked well. I tried to make a new bot, but it failed.

I recently heard that MongoDB has been updated. I think you’re having the same problem as me.

Help me!