Error during mongo realm function call from flutter using realm flutter sdk

Hey everyone, i currently am building a flutter app and using mongo realm for authentication ,index searching as well as function call capabilities.

Everything was working fine until i ran the command: flutter upgrade, which afterwards lead to the following errors being thrown when i launch my app:

D/libGLESv2( 6862): STS_GLApi : DTS, ODTC are not allowed for Package : com.example.auction_app
I/flutter ( 6862): 2023-11-18T22:15:45.054885: [ERROR] Realm: HTTP Transport: Exception executing get HandshakeException: Handshake error in client (OS Error: 
I/flutter ( 6862):      CERTIFICATE_VERIFY_FAILED: certificate has expired(
I/flutter ( 6862): an error has occured during retrieveAllProducts function
I/flutter ( 6862): AppException: non-zero custom status code considered fatal, status code: 999
I/flutter ( 6862): []
I/flutter ( 6862): 2023-11-18T22:15:45.240942: [ERROR] Realm: App: log_in_with_credentials failed: 0 message: non-zero custom status code considered fatal

i did some googling and found out about the need to add the following line to androidmanifest.xml file:
<uses-permission android:name="android.permission.INTERNET" />
but that didn’t fix the issue unfortunately.

  • i did allow access from anywhere in the realm Application settings
  • i did allow anonymous authentication in the app

here is the flutter code:

Future<List<dynamic>> retrieveAllProducts(arg) async {
    print("RetrieveAllProducts Function");
    try {
      final user = await app.logIn(emailPwCredentials);
      products = await'allProducts');
    } catch (e) {
      print('an error has occured during retrieveAllProducts function');
    return products;

Does anyone know any solution to such problem?
(Again everything was working fine, until i ran the command flutter upgrade )

@Djamel_Abbou Were you able to solve this issue ?

This is likely the same issue as Realm: HTTP Transport: Exception executing get{appId}/location · Issue #1430 · realm/realm-dart · GitHub. You can try the workaround proposed there and verify whether it solves the issue for you.