Debian 10 install - unable to locate package mongodb-org

I’m trying to install MongoDB on a new chromebook running an ARM version of Debian 10. I followed the instructions in the docs but I keep getting the unable to locate package mongodb-org error. The docs don’t have the [arch=arm64] option, so I tried adding that, but still get the same issue. I see the arm version is in the place that my list file mentions (MongoDB Repositories). Here is what my list file looks like:

deb [arch=arm64] buster/mongodb-org/5.0 main

As mentioned, I’ve tried this with and without the [arch=arm64] and get the same results. Any suggestions would be appreciated!

Just to clarify, I’m really just looking to install the community version of MongoDB at this time.

1 Like

Same issue here with raspberry in debian, only works with ubuntu:

Welcome to the MongoDB Community Forums @Patricio_Ascencio!

Debian 10 currently isn’t a supported platform for ARM64 packages for MongoDB 5.0. There is an open request to Support Debian 10 (Buster) on ARM64 which you can watch & upvote.

However, if you are trying to install MongoDB 5.0 on a Raspberry Pi there is a further caveat: MongoDB 5.0+ packages on arm64 require the ARMv8.2-A or later microarchitecture, which means the precompiled binaries (if available for your O/S) would not run on current Raspberry Pi models.

The workaround is to either build from source (cross-compiling highly recommended) or to install the MongoDB 4.4 ARM64 packages. For more discussion see Core dump on MongoDB 5.0 on RPi 4 - #14 by Stennie_X.


Hi! I have compiled MongoDB 5.0.x for Raspberry Pi OS 64-bit on an R-Pi 4. You can check it out on the Andy Felong Blog.

1 Like