Connection to VS Code

When connecting to VS Code, when I enter my password, which has a % in it, but I receive ‘URI malformed’ error.
Screen Shot 2022-09-23 at 8.11.11 AM

I tried to change my password, but I was receiving the following error in my terminal.
mongo use products
db.changeUserPassword(“myUserAdmin”, passwordPrompt())

zsh: parse error near `)’

Any guidance would be a great help!

It could be quotes around your user
Use double quotes.Your quotes look different

Thanks for the feedback! I tried double quotes = " - and also tried single quote ’ - no dice :confused: any other suggestions?

Don’t use pwd prompt.Add your password directly in the command and see if it works

Why are you trying to run MongoDB command from your terminal prompt? The error in the screnshot is coming from the zsh shell not understanding what you’re typing.

You want to run mongo by itself to start the older mongo shell. After that starts and you are connected to the server then you can run your other commands.

1 Like