Connection issue with the cluster

I was working on a project and suddenly mongodb cluster was deleted and couldn’t find it, then I created a new cluster and tried to connect and unable to do so. I tried to connect through compass and still unable to connect. I have add my 0.0.0.0/0 to Ip access list but still couldn’t connect to it

We do not have enough information to help you.

Post a screenshot of what you are doing that shows the issue you are having.

So Initially below is my cluster which was automatically deleted.

mongodb+srv://dbuser:<password>@cluster0.egv6d.mongodb.net

This is my new cluster

mongodb+srv://dbuser:<password>@cluster0.narb2.mongodb.net

When I tried to connect to cluster using compass I am getting timeout error.
![image|690x421](upload://uz0G81CR4T45rMDQeRH8wHM3ajv.jpeg
above screen appears for very long time.
When I use the cluster connection in the node getting unable to get data.

UnhandledPromiseRejectionWarning: MongooseError: Operation `users.findOne()` buffering timed out after 10000ms

Below image is what I am getting when I try to connect to cluster using Compass.


And also in the recently used section contains the deleted cluster which I mentioned in the first point.

below is the newly created cluster which I couldn’t access.

Have you change computer, internet provider, vpn provider or location? It looks like a networking issue from your side.

Both clusters seem ok. Perhaps cluster0.egv6d.mongodb.net was created in another project. That would explain why you do not see it in Atlas.

You prob need to change your IP. Anytime you get that error is related to the network access. Try 0.0.0.0/0 as it will include your current IP address. It usually works.