Connecting Retool to MongoDB - not authorized on <DATABASE> to execute command

Hello, I am trying to connect a MongoDB which we’ve been given limited and specific access to. We are able to access a specific index within a specific collection and database. I am able to use MongoDB Compass to query the data in that specific index, but attempting to access it via a third party resource (such as Retool) fails. I have also tried to use other web apps which connect to MongoDB, but all fail as well.

I am trying to connect using the srv connection URL, however every attempt across these third party providers throws the same error:

not authorized on <DATABASE> to execute command

Although the error is self explanatory, what I don’t understand is that I can access in Compass normally but cannot with other db applications or integrations.

Would love any suggestions or guidance from the community, thanks in advance!

Those other tools are trying to run commands(probably unnecessarily) to gather some information, either about the cluster or the databases/collections in the cluster.

They may have options to disable these or not.

Observing the client or server logs could show what commands they expect to run, and modify the role to allow these commands.