Connecting MongoDB With Godot Engine Gives A Timeout Error

Similar to the post Chris_Findlay made here Driver for Godot Engine, I have a timeout error when I ping the DB too, I’ve tried updating the version for both MongoDB.Driver to v2.22.0 and intalling DnsClient v1.7.0 but the error is still there…

I tried creating a empty project with VS and ping the Mongodb database and it was working, but building the exact same code from godot seems to have a time out error, I’m using godot v3.5.2, .net version btw

Here’s the error msg:

System.TimeoutException: A timeout occurred after 30000ms selecting a server using CompositeServerSelector{ Selectors = ReadPreferenceServerSelector{ ReadPreference = { Mode : Primary } }, LatencyLimitingServerSelector{ AllowedLatencyRange = 00:00:00.0150000 }, OperationsCountServerSelector }. Client view of cluster state is { ClusterId : "1", ConnectionMode : "ReplicaSet", Type : "ReplicaSet", State : "Disconnected", Servers : [{ ServerId: "{ ClusterId : 1, EndPoint : "Unspecified/" }", EndPoint: "Unspecified/", ReasonChanged: "Heartbeat", State: "Disconnected", ServerVersion: , TopologyVersion: , Type: "Unknown", HeartbeatException: "MongoDB.Driver.MongoConnectionException: An exception occurred while opening a connection to the server. ---> System.Security.Authentication.AuthenticationException: Authentication failed, see inner exception. ---> Mono.Btls.MonoBtlsException: Ssl error:1000007d:SSL routines:OPENSSL_internal:CERTIFICATE_VERIFY_FAILED
  at /root/mono-
  at Mono.Btls.MonoBtlsContext.ProcessHandshake () [0x00048] in <fb5bab3549ab4d3a9063ade7c170458f>:0 
  at Mono.Net.Security.MobileAuthenticatedStream.ProcessHandshake (Mono.Net.Security.AsyncOperationStatus status, System.Boolean renegotiate) [0x000da] in <fb5bab3549ab4d3a9063ade7c170458f>:0 
  at (wrapper remoting-invoke-with-check) Mono.Net.Security.MobileAuthenticatedStream.ProcessHandshake(Mono.Net.Security.AsyncOperationStatus,bool)
  at Mono.Net.Security.AsyncHandshakeRequest.Run (Mono.Net.Security.AsyncOperationStatus status) [0x00006] in <fb5bab3549ab4d3a9063ade7c170458f>:0 
  at Mono.Net.Security.AsyncProtocolRequest.ProcessOperation (System.Threading.CancellationToken cancellationToken) [0x000fc] in <fb5bab3549ab4d3a9063ade7c170458f>:0 
   --- End of inner exception stack trace ---

I’ve tried downgrading MongoDB.Driver to v2.10.3, DnsClient to v1.3.1 but I get the same error as before