Connect to your Atlas Cluster


I’m having trouble completing the last section of Chapter 1 for course M001, Connect to your Atlas Cluster.

I have copied the connection string from as instructed in the exercise and have entered it in the IDE.

My connection string is: mongo “mongodb+srv://” --username m001-studentimage screenshot 3 screenshot1

I have tried changing the dbname to test so the string reads as below, as I’ve read on these forums suggestions to try test database, but no luck.

mongo “mongodb+srv://” --username m001-student

Screenshots attached for reference.

Can someone please kindly advise on this.

Please revise the section where the IDE is presented. You missed some fundamental concepts as you have entered the command in the file editing area.

HI @J_Lei,

Please enter the command in the terminal area and hit enter to connect to your Atlas cluster.

Hi @Shubham_Ranjan
The same issue was occuring for me too. I tried changing the dbname and entered the string in the terminal. Yet, the answer was shown to be incorrect. Could you please help me figure out what exactly do I do?
Thank you & Regards

1 Like

Did you hit enter after entering the string in terminal area?
Please run the test results while you are connected to your cluster

Hi @Harshita_Kaur,

Please share a screenshot of the command that you ran and the output of the test result.

~ Shubham

Hello @Shubham_Ranjan
Thank you for replying. I actually got the issue resolved. I connected my cluster to the IDE a few hours back.

Hi @Harshita_Kaur,

I’m glad your issue got resolved. Please feel free to get back to us if you face any other issue.

~ Shubham

how to use browser ide , what is the url for browser ide

Please check this

How to open in browser ide?

Hi @Narasimha_27715,

I hope your doubts are clear now. Let us know if you have any other questions.

~ Shubham

Hi All,

I am not able to connect to atlas sandbox cluster. Below is the screenshot of the error.

logs.txt (4.0 KB)

I have also attached full logs. please help.

Thank you

You must provide the username and password.

Hi @steevej-1495,

Thank you for you reply.

I am providing Username and password as below

connection string - mongo “mongodb+srv://” --username m001-student

Password - m001-mongodb-basics

My guess, then, is that you did not created the user correctly in Atlas.

I would recreate it by typing manually rather than cut-n-paste. Sometimes, white spaces are cut-n-pastes.

how to find out the name of the database?

You can use test for now.It will put you in test DB(it is a dummy/default DB )
Once you create different DBs in your Sandbox cluster you can replace test with whatever DB you wish to connect

Thank you for you reply.

how to fix this problem?

connnect atlas2

You were supposed to name your cluster Sandbox but you named it Cluster0.

You have to terminate your current cluster and create a new one with the appropriate name.