I have a connection string as below.


When connecting through Mongo getting error as connect ETIMEDOUT. The version of the compass that I am using is 1.30.1.

Can someone help if I am missing something?

Did it work before?
You may have to append your string with &appname=MongoDB%20Compass
Can you connect by shell?
You can get exact connect string from your Atlas account
For latest mongodb versions you can use SRV type string
Also you can try to connect by fillings individual fields (Fill in connection fields individually option) under new connection page

Hi @Ramachandra_Tummala ,

I have tried appending &appname=MongoDB%20Compass to the connection sting but that didn’t help. And tried connecting through shell as below but didn’t succeed. Am I missing something?

Now I started getting response as below

In the first snapshot i think you were running the command at mongo prompt.Run it from your terminal prompt(os prompt)
In the second one you might have run without enclosing the connect string in quotes.
Try mongo “your connect string”