Conflicts on Mongodb-client installation

I am getting conflicts on mongo-client installation. I have already installed mongodb community version. Command for mongo-client installation and erros are mentioned below.

mtechcse@mtechcse-Precision-Tower-5810:~$ sudo apt install mongodb-clients
[sudo] password for mtechcse:
Reading package lists… Done
Building dependency tree
Reading state information… Done
You might want to run ‘apt --fix-broken install’ to correct these.
The following packages have unmet dependencies:
mongodb-org : Conflicts: mongodb-clients but 1:3.6.3-0ubuntu1.4 is to be installed
mongodb-org-database : Conflicts: mongodb-clients but 1:3.6.3-0ubuntu1.4 is to be installed
mongodb-org-database-tools-extra : Conflicts: mongodb-clients but 1:3.6.3-0ubuntu1.4 is to be installed
mongodb-org-mongos : Conflicts: mongodb-clients but 1:3.6.3-0ubuntu1.4 is to be installed
mongodb-org-server : Conflicts: mongodb-clients but 1:3.6.3-0ubuntu1.4 is to be installed
mongodb-org-shell : Conflicts: mongodb-clients but 1:3.6.3-0ubuntu1.4 is to be installed
mongodb-org-tools : Depends: mongodb-database-tools but it is not going to be installed
Conflicts: mongodb-clients but 1:3.6.3-0ubuntu1.4 is to be installed
E: Unmet dependencies. Try ‘apt --fix-broken install’ with no packages (or specify a solution).

Not able to solve this conflict even by --fix-broken option

mtechcse@mtechcse-Precision-Tower-5810:~$ sudo apt --fix-broken install
[sudo] password for mtechcse:
Reading package lists… Done
Building dependency tree
Reading state information… Done
Correcting dependencies… Done
The following packages were automatically installed and are no longer required:
libboost-program-options1.65.1 libgoogle-perftools4 libpcrecpp0v5
libsnappy1v5 libtcmalloc-minimal4 libyaml-cpp0.5v5
linux-hwe-5.4-headers-5.4.0-105 linux-hwe-5.4-headers-5.4.0-107
linux-hwe-5.4-headers-5.4.0-110 linux-hwe-5.4-headers-5.4.0-113 mongo-tools
Use ‘sudo apt autoremove’ to remove them.
The following additional packages will be installed:
mongodb-database-tools
The following NEW packages will be installed:
mongodb-database-tools
0 upgraded, 1 newly installed, 0 to remove and 3 not upgraded.
2 not fully installed or removed.
Need to get 0 B/47.7 MB of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y
(Reading database … 307077 files and directories currently installed.)
Preparing to unpack …/mongodb-database-tools_100.6.0_amd64.deb …
Unpacking mongodb-database-tools (100.6.0) …
dpkg: error processing archive /var/cache/apt/archives/mongodb-database-tools_100.6.0_amd64.deb (–unpack):
trying to overwrite ‘/usr/bin/bsondump’, which is also in package mongo-tools 3.6.3-0ubuntu1
dpkg-deb: error: paste subprocess was killed by signal (Broken pipe)
Errors were encountered while processing:
/var/cache/apt/archives/mongodb-database-tools_100.6.0_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Hi @Prof_Monika_Shah, can you provide the results of mongo --version. I’m wondering if you installed an old version of MongoDB.

Here are the steps to install MongoDB 6.0 on Ubuntu 20.04.