Complete uninstall of MongoDBCompass windows

I have one server that will not launch any version of mongodbcompass. Last successful version that opened on that server was 1.26.5, which I installed and opened, did what I needed to and then closed everything and logged off the server. Tried opening it a few days ago and it just spawns tasks in Tasks Manager but never starts or shows the GUI. I tried upgrading to 1.30.1, nothing. Rolled back to 1.26.5, nothing. Tried all of the release in between and each does the same thing (nothing but spawn tasks) so I think there is something installed that is not written over that I am not getting and its causing the problem to continue with each version. I’ve deleted the folders create in the user’s local and roaming folders, but still, no GUI. The tasks in the manager keep growing until I cancel them. 1.30.1 installed on other servers works fine… for now.

Is there a complete uninstall guide for windows somewhere?

What is your ultimate goal? Installed a working copy of Compass or completely wipe out Compass from your system.

It looks like your real issue is

but that does not make a lot of sense. Post a screenshot of what you are doing the illustrate the real issue you are having about not launch any version. Compass crashes, cannot connect?

@Jeff_Kling, have you been able to achieve your goal? If so please share the solution for the benefit to all.

Sorry for the delay, I haven’t found a solution to this. I installed NoSqlBooster to work with the db in the interim.

My ultimate goal is to get compass to open and to function.


Since it is not even opening to the GUI, in any version I tried as noted, I thought there may be some deeply installed part of compass that is not getting updated when I tried other versions so hence, doing a clean wipe of everything Compass and starting over.

There really is no screen shot I can show- it would just be my desktop because compass NEVER opens… the only hint that something is occurring is the tasks in the Task Manager:

compass

Let it run for 3 hours and the size is now 1,744 MB, still no GUI opened.
compass2

Which Windows?

What are the specs of your machine?

Where did you download Compass from?

Windows server 2019 10.0.17763
2 core 2.90Ghz
16gb ram + 9gb virtual ram
100gb free space

Downloaded from the official download page: https://www.mongodb.com/try/download/compass
It worked once when I set everything up- but hasn’t opened since.

The server specs that works:
Windows server 2019 10.0.17763
4 core 2.30Ghz
16gb ram
15gb free space

Also downloaded from: https://www.mongodb.com/try/download/compass

Sorry but I have no clue.

1,744 is enormous compare to what I see on my system. Only firefox comes close to that but with a few windows and couples of tabs.

Hopefully somebody from MongoDB will pitch in.

@Jeff_Kling sorry for the late follow-up. We are currently investigating this. Question: did you install Compass with the EXE or with the MSI installer?

Hi There! No worries. I have been chatting with Felicia on the Jira bug tracker here
and she suggested trying the beta release and it has been working as it should so I think they were able to fix the issue.

For your question, I tried both installers and got the same result for each when I had this problem.