Community 7.0 won't connect on Mac OS 15 - punycode deprecation warning

I have installed community@7.0 on Mac OS Sonoma 14.1.2. mongosh fails to connect with ‘[DEP0040] DeprecationWarning: The punycode module is deprecated. Please use a userland alternative instead.’ error.

I have tried npm install punycode (and npm update) but error remains. Is there an alternative solution?

3 Likes

Facing same issue, here is the stackoverflow issue with more details. This is blocking local testing for us.

[database - Issue while running MongoDB on Mac - DeprecationWarning: The `punycode` module is deprecated. Please use a userland alternative instead - Stack Overflow](https://StackOverFlow issue link)

1 Like

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.