Can't run 'mongorestore' with GLIBC 2.31

when I want to use the ‘mongorestore’ command, I got an error about the ‘GLIBC’ version that I’m using.

$ mongorestore --version
>> mongorestore: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.32' not found (required by mongorestore)
>> mongorestore: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.34' not found (required by mongorestore)

I’m using MongoDB 5.06 and Ubuntu 20.04, and got installed the next GLIBC version: ‘(Ubuntu GLIBC 2.31-0ubuntu9.14) 2.31’

Can you help me with this problem?

I tried to use the ‘Mongorestore’ command in Ubuntu 20.04, with MongoDB 5.06 and GLIBC 2.31, but the message that I receive is that I need to update the GLIBC version to 2.32 or 2.34, but I don’t have access to update this GLIBC in the virtual machine.

You may have the binaries for Ubuntu 22.04 instead, this would require the GLIBC dependencies shown.

22.04:

objdump -T mongodb-database-tools-ubuntu2204-x86_64-100.9.4/bin/mongorestore | grep -o 'GLIBC[^ ]\+' | sort -V | uniq
GLIBC_2.2.5
GLIBC_2.3.2
GLIBC_2.3.4
GLIBC_2.4
GLIBC_2.14
GLIBC_2.32
GLIBC_2.34

vs 20.04:

objdump -T mongodb-database-tools-ubuntu2004-x86_64-100.9.4/bin/mongorestore | grep -o 'GLIBC[^ ]\+' | sort -V | uniq
GLIBC_2.2.5
GLIBC_2.3.2
GLIBC_2.3.4
GLIBC_2.4
GLIBC_2.14