Can't install Mongo on Rock Linux 9

Hoping to get some help. We are using the Cloud Manager product for managing a 3 node replica set. Has worked great for many years.

We are trying to add additional nodes to our replica set using the Cloud Manager but the installation keeps failing. We are running Rocky Linux 9.3 on the new nodes and have install the automation manager via Cloud Manager. However, when we attempt to add the node we get the following error:

** Updated error to remove hostnames

Error retrieving cluster config from 'https://api-agents.mongodb.com/agents/api/automation/conf/v1/54dda405e4b001609834e83f?av=13.14.1.8759&ag=9d43c6b5ad33f49750a7561fc02a8d2326b3491f&aos=linux&aa=x86_64&ab=64&ad=&ah=XXXXXX.com&ahs=XXXXXX.com&at=1713191005376' : [10:03:20.591] Error validating semantics during expansion : [10:03:20.591] Cluster config did not pass validation for pre-expansion semantics : MongoDB version 6.0.14 for process = pbReplicaSet_16 was not found in the list of available versions : [ 6.0.14 : &{linux https://fastdl.mongodb.org/linux/mongodb-linux-x86_64-ubuntu2204-6.0.14.tgz 25225db95574916fecab3af75b184409f8713aef [] amd64 ubuntu 22.04 23.04 false},&{linux https://fastdl.mongodb.org/linux/mongodb-linux-aarch64-ubuntu2204-6.0.14.tgz 25225db95574916fecab3af75b184409f8713aef [] aarch64 ubuntu 22.04 23.04 false},&{linux https://fastdl.mongodb.org/linux/mongodb-linux-aarch64-ubuntu2004-6.0.14.tgz 25225db95574916fecab3af75b184409f8713aef [] aarch64 ubuntu 20.04 21.04 false},&{linux https://fastdl.mongodb.org/linux/mongodb-linux-x86_64-ubuntu2004-6.0.14.tgz 25225db95574916fecab3af75b184409f8713aef [] amd64 ubuntu 20.04 21.04 false},&{osx https://fastdl.mongodb.org/osx/mongodb-macos-x86_64-6.0.14.tgz 25225db95574916fecab3af75b184409f8713aef [] amd64 false},&{linux https://fastdl.mongodb.org/linux/mongodb-linux-x86_64-rhel70-6.0.14.tgz 25225db95574916fecab3af75b184409f8713aef [] amd64 rhel 7.0 8.0 false},&{linux https://fastdl.mongodb.org/linux/mongodb-linux-x86_64-debian11-6.0.14.tgz 25225db95574916fecab3af75b184409f8713aef [] amd64 debian 11.0 12.0 false},&{linux https://fastdl.mongodb.org/linux/mongodb-linux-x86_64-amazon2-6.0.14.tgz 25225db95574916fecab3af75b184409f8713aef [] amd64 amazon2 2 false},&{linux https://fastdl.mongodb.org/linux/mongodb-linux-x86_64-suse12-6.0.14.tgz 25225db95574916fecab3af75b184409f8713aef [] amd64 suse 12 13 false},&{windows https://fastdl.mongodb.org/windows/mongodb-windows-x86_64-6.0.14.zip 25225db95574916fecab3af75b184409f8713aef [] amd64 false},&{linux https://fastdl.mongodb.org/linux/mongodb-linux-x86_64-ubuntu1804-6.0.14.tgz 25225db95574916fecab3af75b184409f8713aef [] amd64 ubuntu 18.04 19.04 false},&{linux https://fastdl.mongodb.org/linux/mongodb-linux-x86_64-suse15-6.0.14.tgz 25225db95574916fecab3af75b184409f8713aef [] amd64 suse 15 16 false},&{linux https://fastdl.mongodb.org/linux/mongodb-linux-aarch64-ubuntu1804-6.0.14.tgz 25225db95574916fecab3af75b184409f8713aef [] aarch64 ubuntu 18.04 19.04 false},&{linux https://fastdl.mongodb.org/linux/mongodb-linux-x86_64-debian10-6.0.14.tgz 25225db95574916fecab3af75b184409f8713aef [] amd64 debian 10.0 11.0 false},&{linux https://fastdl.mongodb.org/linux/mongodb-linux-x86_64-rhel80-6.0.14.tgz 25225db95574916fecab3af75b184409f8713aef [] amd64 rhel 8.0 9.0 false},&{linux https://fastdl.mongodb.org/linux/mongodb-linux-x86_64-rhel90-6.0.14.tgz 25225db95574916fecab3af75b184409f8713aef [] amd64 rhel 9.0 10.0 false},&{linux https://fastdl.mongodb.org/linux/mongodb-linux-aarch64-rhel90-6.0.14.tgz 25225db95574916fecab3af75b184409f8713aef [] aarch64 rhel 9.0 10.0 false},&{linux https://fastdl.mongodb.org/linux/mongodb-linux-aarch64-rhel82-6.0.14.tgz 25225db95574916fecab3af75b184409f8713aef [] aarch64 rhel 8.0 9.0 false},&{linux https://fastdl.mongodb.org/linux/mongodb-linux-aarch64-amazon2-6.0.14.tgz 25225db95574916fecab3af75b184409f8713aef [] aarch64 amazon2 2 false} ]

Hello

As a result of the error check, you are trying to install version 6.0.14, but Rocky 9 supports version 6.0.4 or higher.[MongoDB version 6.0.14 for process = pbReplicaSet_16 was not found in the list of available versions : ]
Check the link to see which versions are supported

Thank you

Also, I’d like to add I can manually install mongo 6.0.14 on the machine directly via dnf. The issue is the automation agent can’t.

Your response doesn’t make sense… 6.0.14 is greater than 6.0.4 so that isn’t the issue. I am trying to install a supported version (6.0.14).

Sorry, my mistake. I checked the wrong version.

No worries, I really appreciate you trying to help. Hoping someone can chime in here and help me resolve the issue.