Can't install mongo on macOS

While I want to install Mongo on my PC I get such an error (executing mongo --nodb):
“mongo” cannot be opened because the developer cannot be verified.
macOS cannot verify that this app is free from malware.

Do you happen to know what should I do?

This link from :green_apple: should help:


Hi @Agnieszka_Morzywolek_63138,

I hope you found @007_jb’s response helpful. Please let us know if you are still having any issue.

Shubham Ranjan
Curriculum Services Engineer

I have the same issue. I used the information from the link but still same error.

When I ran mongo --nodb command in terminal, I see the below error as command not found

Responded to you on other thread

Correct your mongodb path
It should work

What do you mean by correct your mongodb path?
Is the following not correct?
bash-3.2$ /Users/lilianetop/Desktop/mongodb-macos-x86_64-4.4.0/bin

Have you been able to solve it?

I solved it as I downloaded the wrong package. The confusion comes from the screens shown are outdated and incomplete.

Yes, I resolved it and agree with you as some of the instructions are confusing and outdated.

Hi @Liliane_Top,

I’m glad your issue got resolved and thanks for the feedback. We will shortly update the instructions.

~ Shubham

Hi! I’m facing the same issue with installing Mongo on macOS.
I’ve set the path and when trying to run mongo I receive this error:

follow the instruction to update your path or specify the full path name of the command

I followed the instruction. The .tar file is mongodb-macos-x86_64-enterprise-4.4.1.tgz
The path specified in the /etc/paths is /Users/anastasia/Desktop/mongodb-macos-x86_64-enterprise-4.4.1/bin
yet after the restart the mongo is not started

Hi @Anastasia_Alexandrova,

What’s the output of this command ?

echo $PATH

I can see you are currently using bash shell but did you switch to bash shell before setting the path ?

@Shubham_Ranjan , I did switch to bash shell before updating /etc/paths
the output of echo $PATH is /Users/anastasia/.pyenv/shims:/Users/anastasia/go/bin:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin

But mongodb/bin is missing in your path
If you have edited the file and saved it you should see the path
Can you show contents of /etc/paths

Hi @Anastasia_Alexandrova,

Please share the information requested by @Ramachandra_37567.

~ Shubham

Hi all! I’ve added the path to mongodb in my .zshrc file and then I was able to start mongo shell.

Hi @Anastasia_Alexandrova,

I’m glad your issue got resolved. Please feel free to get back to us if you face any other issues.

~ Shubham