Can Debian 12 Compile and Install MongoDB v4 and v5?

The Linux (legacy) x64 installation package stopped updating at v4.0.27.

Currently, I have successfully deployed MongoDB v3.4 on Debian 12.

I want to know if Debian 12 can compile versions v4 and v5 of MongoDB. This is crucial for updating my environment.

I attempted to compile MongoDB v5 on Debian 12, but it seems to have failed due to SSL reasons.

This solved my problem.

wget http://ftp.de.debian.org/debian/pool/main/o/openssl/libssl1.1_1.1.1w-0+deb11u1_amd64.deb
dpkg -i libssl1.1_1.1.1w-0+deb11u1_amd64.deb

Debian 12 Only supports MongoDB version 7 per:

https://www.mongodb.com/docs/manual/installation/#supported-platforms

1 Like

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.