Building mongo-c-driver on windows

I have been trying to install and build the mongo c and mongo cxx libraries on my windows machine for an entire week now, and haven’t been able to do it. When I try to build the mongo cxx driver, I get an error that says moreless the following "cannot find package LIBBSON-1.0; didn’t provide a libbson-1.0-config.cmake file. After a few days, I realized that obviously the mongo c driver hadn’t been properly built, since libbson and libmongoc had been installed with the Ubuntu bash shell, and Windows is not able to access that files and if it was, it could not compile them because they belong to different operating systems. My question here is: could you please provide a few steps to install libbson and libmongoc on windows (not ubuntu or macOS or linux) and a really simple guide to build the rest of the libraries? Something really simple, just the commands to type in order to build them properly. I have been trying to do this for a really long time, and I already feel that I need help from true experts. I would be really grateful with any kind of help. Thank you in advance!

PD: I have already tried installing it following the instructions on the official guide, and it didn’t work for me. I tried to install it combining Windows cmd and Ubuntu bash shell, and it didn’t work. I cannot find any way to execute some commands on windows cmd, such as installing libbson and libmongoc

@Josemi_Quilez, the instructions you reference have been around for quite some time and have worked for many users. Please have a look at the guidelines for asking for help with C driver build failures and then provide the additional necessary information. That should enable us to provide more specific assistance.

Hello @Roberto_Sanchez:
Thanks for your help. I haven’t been able to do many things today unfortunately, but tomorrow I will post a new comment with the neccesary instructions to test the error. I order to test it, I will also post a github repository so you can reproduce the error on your machine (it is pretty straightforward). To give you a basic idea about it, when I compile a node addon on Ubuntu including the drivers it works properly, but when I try to do the same on Windows it returns syntax error in relation to view.hpp and element.hpp mongocxx library files (extremely rare I think, it detects the syntax of the files from the built driver as invalid). I have tested every possible solution I came across and up with over a week, and haven’t been successful.
Anyway, tomorrow (in 20 hours aprox) I will post all the instructions required and the github repository.
A great thanks for your help again, and sorry for the delay!
Yours faithfully,