Atlas DB / Federated databases while using Tableau –

We are running into some issues with Atlas DB / Federated databases while using Tableau –

We have tried working with the sample data from the AWS instance and that is working with Tableau, but now we are trying to connect with our database instance.

Any suggestions? We are completely stuck…

Not much out there to help with this issue.

from Mongodb log files
{“level”:“info”,“timestamp”:“2023-03-10T21:28:54.524Z”,“logger”:“command”,“msg”:“failed to parse command”,“hostname”:“”,“correlationID”:“174b2c10459967288af2d484”,“commandName”:“unknown”,“error”:“command endSessions is unsupported”,“ts”:1678483734524462721}

{“level”:“debug”,“timestamp”:“2023-03-10T21:28:54.565Z”,“msg”:“dropping connection with read error”,“hostname”:“”,“bytesRead”:0,“error”:“an internal error occurred”,“ts”:1678483734565696550}

{“level”:“warn”,“timestamp”:“2023-03-10T21:28:54.565Z”,“msg”:“failed reading message from client”,“hostname”:“”,“error”:“an internal error occurred”,“ts”:1678483734565742351}

Hi @Sam_Marrazzo, My name is Alexi Antonino and I am the product manager for Atlas SQL, Tableau Connector. I can help you if you’d like. Can I have a bit more information? Did you follow these steps to connect from Tableau? And are you getting an error from within Tableau? Are you connecting with Tableau Desktop. Server, or Prep? Our connector doesn’t support Tableau Online just yet.
If it is easier, we can communicate via email and set up a call so that I can view first hand where you are getting blocked.


Yes we did follow the directions you posted and we tried to and it worked connecting to the AWS sample data.
We are getting an error within Tableau our team will send you the exact error to your email we receive from Tableau
We are using Tableau Desktop -

Thanks @Sam_Marrazzo - I will be on the look out for that specific email with the error!