Any way to recovery from error 62 without losing data?

Hi there.

I blindly updated mongo to 7.0 without any backups and without setting the feature compatibility command, and now I’m getting error 62 when trying to start.

Is there any way to fix this without deleting the /var/lib/mongodb directory (without losing the data)?


Good afternoon, welcome to the MongoDB community.

You can downgrade the cluster and try starting to see what the problem is. Also, don’t you have replicas in your cluster?

I just tried that after making the post. Started all over again following the update guide and everything worked fine.

Seems the issue was caused because of featureCompatibilityVersion set to 5.0 instead of 6.0 before upgrading. Because when I deleted the removed storage.journal.enabled config after updating to 7.0 I got the error 62.

This is just a dev server I have working as standalone, so no replicas.

Thanks anyway :slight_smile:

1 Like

I’m glad you got it resolved, I’m at your disposal!

1 Like

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.