Announcing MongoDB Realm and Realm Sync public beta

Hi everyone!

Exciting news - today, we announced both the release of MongoDB Realm and the public beta of the new Realm Sync service!

You can check out our release blog post here: and read the documentation here:

We are hosting some sessions on Realm’s services as part of the event, which you can attend for free today and tomorrow: (Note: Even if you can’t make it this week, most sessions will be available on demand after the event)

We really want to hear from you during the Realm Sync beta. You can head to to share your feedback as you start building.

Drew, Product Lead for MongoDB Realm


We were looking forward to attending this event and really interested in the MongoDB Realm sessions (are the sessions listed somewhere?)

However, we first try to access the site we get this

And then using a different browser, we attempt to register and get this

It should not be this difficult to attend an event.

In the first browser please try clicking “Continue” under the section you’ve screenshotted. Popup blockers are integrated into all browsers so this is the expected result and once you click continue below this you’ll be in.

That was the first thing we tried!

It presented that error in Safari so we switched over to Firefox and received the same messages when attempting to use the site and then register.

I then tried it on my iPad with the same results. I had one of my engineers working from home try it. He already tried it on multiple devices and it never worked so he gave up.

I know this isn’t a support forum so thanks for responding anyway.

We’re here to help. We have seen a couple similar reports and I’ve just been notified that a fix is being deployed for the registration and login issues.