Android With Kotlin Tutorial

I am trying to follow the Android With Kotlin Tutorial to establish if device sync will work for us but I am unable to get it to work.

Initially the application gets stuck on a standard android spashscreen after loggin in, then if I restart the app I can add items to a todo list however nothing is synched with the back end. The Android logcat just keeps outputing the same error

REALM W [Core] Reading failed: End of input

I’ve tried deleting the application and starting a fresh several times but the result is the same and as I am new to mongodb and atlas I don’t know where to look to see what is causing the issue. Can anyone suggest what the problem might be and/or confirm that the tutorial I am following currently works?

Additionally when I downloaded the template app zip folder it was empty so I had to use the CLI.

Is it possible you didn’t add your app ID to your configuration?

In Android Studio, open the kotlin.todo.flex folder located in the frontend folder of the template app.
If you downloaded the client as a .zip file or cloned the client GitHub repository, you must manually insert the App Services App ID in the appropriate place in your client. Follow the Configuration instructions in the client to learn where to insert your App ID.

Thanks for the reply. I used the CLI so the app id was automatically added. I don’t think I would be able to login if it wasn’t there?

I’ve also raised an issue on github which maybe overkill but I can’t figure out what configuration I am missing.