An error occurred while loading navigation: 'not master and slaveOk=false': It is recommended to change your read preference in the connection dialog to Primary Preferred or Secondary Preferred or provide a replica set name for a full topology connection

Why does this error comes up and what does it mean ?
I am using CentOS 7. How can solve this ? Screenshot%20from%202018-11-01%2018-03-52 Image of the connect form and error occured is included.Screenshot%20from%202018-11-01%2018-06-21

1 Like

I have the same problem. How can fix it?

1 Like

Problem Solved All I needed was a reboot of the machine. Hope this works for you!!

1 Like

Hi @Abhishek_16807
I am facing same problem and reboot did not solved it.
Please help

I’m now seeing this issue but we’ve found that if we state we are using SSH then it removes the Replica Set Name field from our connection set up so we’re wondering if it’s related to us using the SSH option. I have to use SSH due to where I work and had to get a colleague to configure me a way out otherwise I was being blocked at every turn.

I am having the same error. @Robert_63090 do you have steps how to setup ssh and use it. I have tried rebooting it and it doesn’t work.

Hi @Vinamra_97063,

Please make sure that you are using correct connection parameters. You can also try to remove the favorite connection and start again.

Also, check the steps mentioned in the following post:
https://www.mongodb.com/community/forums/t/about-the-chapter-1-compass-connection-solution/845

Let me know, if the issue persists.

Thanks,
Sonali

1 Like

@Sonali_Mamgain Thank you. It worked now. I opened the compass again. I removed the favorite and added it again.

1 Like