431 error at GET request after windows reinstall

Hello, I am working on a ecommerce project with react and node and everything worked fine until I had a problem with my laptop and had to reinstall Windows. After OS reinstallation I tried to run my project again but I keep receiving 431 Request Header Fields Too Large error for a GET request. I have no idea how to solve this. I tried different workarounds, even creating a new database with a new connection string but i receive the same error.
Here are the request headers in case it may help you:
GET /api/v1/products?keyword= HTTP/1.1
Accept: application/json, text/plain, /
Accept-Encoding: gzip, deflate, br
Accept-Language: en-US,en;q=0.9
Connection: keep-alive
Host: localhost:4000
Referer: http://localhost:4000/
Sec-Fetch-Dest: empty
Sec-Fetch-Mode: cors
Sec-Fetch-Site: same-origin
User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/116.0.0.0 Safari/537.36 OPR/102.0.0.0
sec-ch-ua: “Chromium”;v=“116”, “Not)A;Brand”;v=“24”, “Opera GX”;v=“102”
sec-ch-ua-mobile: ?0
sec-ch-ua-platform: “Windows”

Check below steps-

  1. Increase Header Size Limit:
  • In your Node.js with Express server, adjust the maxHttpHeaderSize option to allow larger headers.
  1. Check Proxy Configuration:
  • If using a proxy (e.g., Nginx), ensure its configuration accommodates larger header sizes.
  1. Clear Browser Cache and Cookies:
  • Clear your browser’s cache and cookies to eliminate potential conflicts.
  1. Browser and Network Checks:
  • Update your browser to the latest version and check for network issues.
  1. Inspect Request with Tools:
  • Use tools like Postman or cURL to inspect the request and identify potential issues.
  1. Disable Security Software:
  • Temporarily disable security software or firewalls to rule out interference.
  1. Debugging:
  • Implement logging in your Node.js server to debug and analyze the headers.

Apply these steps systematically to pinpoint and resolve the 431 error.

Thank you
stevediazsource