4.4 Server compatibility w/ Async Completable Futures Java Driver

Is 4.4 server (community) compatible with the deprecated async java driver (3.12.3) ? It is difficult to tell from the documentation. My tests locally seem to work.

Yes, it’s compatible. It doesn’t support all the new features of MongoDB 4.4, but we do test the functionality it does provide against MongoDB 4.4.

Regards,
Jeff