Docs Menu

Docs HomeMongoDB Manual

Install MongoDB

On this page

  • MongoDB Installation Tutorials
  • Upgrade Community Edition to Enterprise Edition Tutorials
  • Supported Platforms

Important

MongoDB 5.3 is a rapid release and is only supported for MongoDB Atlas. MongoDB 5.3 is not supported for use on-premises. For more information, see MongoDB Versioning.

To install the latest MongoDB version supported for on-premises use, MongoDB 5.0, see the MongoDB 5.0 installation instructions.

MongoDB is available in two server editions: Community and Enterprise.

This section of the manual contains information on installing MongoDB.

MongoDB installation tutorials are available for the following platforms, for both the Community Edition and the Enterprise Edition:

Platform
Community Edition
Enterprise Edition
Linux
macOS
Windows
Docker

Important

MongoDB 5.3 is a rapid release and is only supported for MongoDB Atlas. MongoDB 5.3 is not supported for use on-premises. For more information, see MongoDB Versioning.

To install the latest MongoDB version supported for on-premises use, MongoDB 5.0, see the MongoDB 5.0 installation instructions.

Changed in version 3.4: MongoDB no longer supports 32-bit x86 platforms.

Important

v4.0 End of Life

v4.0 reached end of life on April 30, 2022 and is no longer officially supported by MongoDB.

Platform
Architecture
Edition
6.0
5.0
4.4
4.2
4.0
Amazon Linux V2
x86_64
Enterprise

Amazon Linux V2
x86_64
Community

Amazon Linux V1
x86_64
Enterprise

Amazon Linux V1
x86_64
Community

Debian 11
x86_64
Enterprise

5.0.8+
Debian 11
x86_64
Community

5.0.8+
Debian 10
x86_64
Enterprise

4.2.1+
Debian 10
x86_64
Community

4.2.1+
Debian 9
x86_64
Enterprise

Debian 9
x86_64
Community

RHEL/CentOS/Oracle Linux/Rocky/Alma 9.0+
x86_64
Enterprise
6.0.3+
RHEL/CentOS/Oracle Linux/Rocky/Alma 9.0+
x86_64
Community
6.0.3+
RHEL/CentOS/Oracle Linux/Rocky/Alma 8.0+
x86_64
Enterprise

4.2.1+
4.0.14+
RHEL/CentOS/Oracle Linux/Rocky/Alma 8.0+
x86_64
Community

4.2.1+
4.0.14+
RHEL/CentOS/Oracle Linux 7.0+
x86_64
Enterprise

RHEL/CentOS/Oracle Linux 7.0+
x86_64
Community

RHEL/CentOS/Oracle Linux 6.2+
x86_64
Enterprise

RHEL/CentOS/Oracle Linux 6.2+
x86_64
Community

SLES 15
x86_64
Enterprise

4.2.1+
SLES 15
x86_64
Community

4.2.1+
SLES 12
x86_64
Enterprise

SLES 12
x86_64
Community

Ubuntu 20.04
x86_64
Enterprise

Ubuntu 20.04
x86_64
Community

Ubuntu 18.04
x86_64
Enterprise

4.0.1+
Ubuntu 18.04
x86_64
Community

4.0.1+
Ubuntu 16.04
x86_64
Enterprise

Ubuntu 16.04
x86_64
Community

Windows Server 2019
x86_64
Enterprise

Windows Server 2019
x86_64
Community

Windows 7/8/8.1
x86_64
Enterprise

Windows 7/8/8.1
x86_64
Community

Windows Server 2008R2/2012/2012R2
x86_64
Enterprise

Windows Server 2008R2/2012/2012R2
x86_64
Community

Windows 10 / Server 2016
x86_64
Enterprise

Windows 10 / Server 2016
x86_64
Community

macOS 11
x86_64
Enterprise

macOS 11
x86_64
Community

macOS 10.14+
x86_64
Enterprise

macOS 10.14+
x86_64
Community

macOS 10.13
x86_64
Enterprise

macOS 10.13
x86_64
Community

macOS 10.12
x86_64
Enterprise

macOS 10.12
x86_64
Community

macOS 11
arm64
Enterprise

macOS 11
arm64
Community

Amazon Linux 2
arm64
Enterprise

4.4.4+
4.2.13+
Amazon Linux 2
arm64
Community

4.4.4+
4.2.13+
RHEL/CentOS/Rocky/Alma 8
arm64
Enterprise

4.4.4+
RHEL/CentOS/Rocky/Alma 8
arm64
Community

4.4.4+
Ubuntu 20.04
arm64
Enterprise

Ubuntu 20.04
arm64
Community

Ubuntu 18.04
arm64
Enterprise

Ubuntu 18.04
arm64
Community

Ubuntu 16.04
arm64
Enterprise

Ubuntu 16.04
arm64
Community

RHEL/CentOS/Rocky/Alma 8
ppc64le
Enterprise

4.2.7+
RHEL/CentOS/Rocky/Alma 8
ppc64le
Community
RHEL/CentOS 7
ppc64le
Enterprise

4.0.0 - 4.0.27
RHEL/CentOS 7
ppc64le
Community
Ubuntu 18.04
ppc64le
Enterprise
4.4.0 - 4.4.10
4.2.1 - 4.2.17
Ubuntu 18.04
ppc64le
Community
RHEL/CentOS/Rocky/Alma 8
s390x
Enterprise

5.0.9+
RHEL/CentOS/Rocky/Alma 8
s390x
Community
RHEL/CentOS 7
s390x
Enterprise

4.2.0 - 4.2.17
4.0.6 - 4.0.27
RHEL/CentOS 7
s390x
Community

4.2.0 - 4.2.9
4.0.6 - 4.0.13
RHEL/CentOS 6
s390x
Enterprise
4.2.4 - 4.2.14
4.0.0 - 4.0.24
RHEL/CentOS 6
s390x
Community
4.0.0 - 4.0.13
SLES 12
s390x
Enterprise
4.4.0 - 4.4.6
4.2.0 - 4.2.14
4.0.6 - 4.0.24
SLES 12
s390x
Community
4.4.0 - 4.4.6
4.2.0 - 4.2.9
4.0.6 - 4.0.13
Ubuntu 18.04
s390x
Enterprise
4.4.0 - 4.4.6
4.2.1 - 4.2.14
4.0.6 - 4.0.25
Ubuntu 18.04
s390x
Community
4.4.0 - 4.4.6
4.2.1 - 4.2.9
4.0.6 - 4.0.13
[1] MongoDB only supports Oracle Linux running the Red Hat Compatible Kernel (RHCK). MongoDB does not support the Unbreakable Enterprise Kernel (UEK).
[2] MongoDB on-premises products released for RHEL version 8.0+ are compatible with and supported on Rocky Linux version 8.0+ and AlmaLinux version 8.0+, contingent upon those distributions meeting their obligation to deliver full RHEL compatibility.
[3] MongoDB versions 5.0 and greater are tested against SLES 12 service pack 5. Earlier versions of MongoDB are tested against SLES 12 with no service pack.
What is MongoDB? →
Share Feedback
© 2022 MongoDB, Inc.

About

  • Careers
  • Investor Relations
  • Legal Notices
  • Privacy Notices
  • Security Information
  • Trust Center
© 2022 MongoDB, Inc.