Docs Menu

Docs HomeMongoDB Manual

Compatibility Changes in MongoDB 5.2

On this page

  • $setWindowFields Stage with Transactions and Snapshot Read Concern
  • Removed Parameters

The following 5.2 changes can affect compatibility with older versions of MongoDB.

In MongoDB versions earlier than 5.3, the $setWindowFields aggregation pipeline stage cannot be used with transactions or the "snapshot" read concern.

MongodB removes the following mongod options:

Removed mongod Options
Description
--cpu
MongoDB 5.2 removes the --cpu mongod option.
←  Release Notes for MongoDB 5.2Release Notes for MongoDB 5.1 →