Docs Menu

Docs HomeMongoDB Manual

CSFLE Compatibility

This page describes the MongoDB and driver versions with which Client-Side Field Level Encryption is compatible.

Automatic encryption with Client-Side Field Level Encryption is only available with MongoDB Enterprise Edition, version 4.2 or later.

Explicit encryption with Client-Side Field Level Encryption is available with MongoDB Community and Enterprise Edition, version 4.2 or later.

Client-Side Field Level Encryption is only available the following official compatible driver versions or later:

Driver
Supported Versions
Quickstarts / Tutorials
Node
3.4.0+
3.11.0+
1.12.0+
3.10.0+
2.10.0+
3.6.0
1.17.5
1.2+
2.7.0+
1.6.0+
2.12.1+

Important

Key Rotation Support

To use the key rotation API of CSFLE, such as the rewrapManyDateKey method, you must use specific versions of either your driver's binding package or libmongocrypt.

The following list details each driver's key rotation API dependencies:

  • If you're using Node.js driver version 6.0.0 or later, mongodb-client-encryption must have the same major version number as the driver. Otherwise, use a 2.x.x version of mongodb-client-encryption that is 2.2.0 or later.

  • Java Driver: Use mongodb-crypt version 1.7.3 or later.

  • pymongo: Use pymongocrypt version 1.3.1 or later.

  • Go Driver: Use libmongocrypt version 1.5.2 or later.

  • C#/.NET Driver: Use the MongoDB C#/.NET Driver version 2.17.1 or later.

Please refer to the driver reference documentation for syntax and implementation examples.

←  ReferenceCSFLE Limitations →