Works in command line but not ide

Refers to Lab: Connect to your Atlas Cluster.

Worked fine when I did it from the command line of my computer. See image.

But cannot get it to work in IDE.

IDE may be using older version of shell
Did you try same command with mongo?

Post a screenshot of what you try in the IDE.

What I tried in IDE. This is driving me crazy. Tried changing username as well.

Yep. No luck. Thanks

I should add that these screenshots record just one of many attempts. Since the problem seems to be user name I even tried adding another user with admin privileges.

I don’t understand how it can work from the command line on my computer and not in the IDE. Everything else seems to work just fine.

You have to press [ENTER] key at the end of the command.

Thank you for that. and once again I exposed my basic stupidity to the whole world. Instead of pressing “enter” I clicked on “RUN TEST”.

The first time I got “mongosh command not recognised.”

Then I tried “mongo” as Ramachandra_Tummala suggested and it worked with the following message:

“WARNING: shell and server versions do not match”

Thanks. Got it to work using “mongo” with message:
WARNING: shell and server versions do not match