Windows 10 error - "hostonlyif "

Im getting the following error when I try “vagrant up” on windows 10

Hi @simonloach,

Please refer this thread and see if it resolves your issue.

Please let me know if the issue still persists.

Shubham Ranjan
Curriculum Services Engineer

Hi, I checked and secure boot is already disabled

thanks Simon

It’s failed to create the private network adapter that VBox creates between the host and the guest machine. Let’s see screenshots of:

  1. Network Connections… all the connections beginning with “VirtualBox”
  2. On VBox > open the settings for the m103 machine > Network tab > Adapter 1 and Adapter 2 (with the advanced button expanded)

Network connections on host machine shows no connections for virtual box
Attached Vbox settings

You forgot to expand the Advanced button, but it’s fine.

As you can see from Adapter 2, VBox failed to create the Host-Only adapter with IP that’s why the tickbox is unchecked. Network Connections indicates the same! So there’s something blocking this from happening.

Try to create it manually:
On VBox > File > Host Network Manager > click Create > *** it may fail here ***
If it doesn’t fail > click Properties > edit the properties to this:

it errors with ;

vb error

Are you using a work laptop? In any case, it could be your anti-virus so try disabling that (if you have the right permissions) and try again.

Also try uninstalling and reinstalling VBox as the Admin.

no its a home laptop … ok so I’ll try the reinstall and disable the antivirus see how I get on

Try the antivirus first before re-installing. :+1:
Edit: Forgot to add, if you do reinstall, ensure that the anti-virus is disabled during installation so that all necessary components are installed.

turned off antivirus , tried create Host Network , same error as before , will try reinstall

uninstalled vbox , rebooted and reinstalled as admin (anti virus turned off)

ran vagrant up --provision , get the following error

What error do you get with a manual creation?

manual creation of “Host Network Manager” ? that seems to work ok ,these two entries are already there

That’s progress! Before we try to attach it manually, did you install VBox as the Admin?

yes installed as admin :slight_smile:

Try this. Open Network Connections and see if the “VBox #2” network is Enabled. If it isn’t, Enable it. If it is, Disable it and re-Enable it. Try vagrant up again.


What’s your version of VBox?

6.0.14 apparently :slight_smile: