While installing requirements.txt

The error is quite clear: the dependent module needs Microsoft Visual C++ to build.
Install Microsoft Visual Studio and try again.

1 Like

the course has this kind of problem with recent python versions, that not all libraries required are compiled/packed for new versions. they are added gradually by the time when library developers have time to do so yet newer version may have missing features leading to errors throughout the course.

It is unfortunate course page does not say what python version is fully compatible. I used python version 3.8 when I took the course and all things were fine. I think 3.7 was also working.

it is already instructed to use virtual python environments for the course, so have one for v3.8 and another for 3.7 and try installing requirements. afterward, you shall have no other problems other than writing correct queries.

1 Like