Where is the zipped handout?

only see pdf in the next lesson…don’t see a zipped handout…in the pdf I don’t see a link to a zipped handout…

" Download the ​m103-vagrant-env.zip from the handouts section of this page. "

Please check again
It will be there

Need m103-vagrant-env.zip

Hi @James_58604,

In each chapter, you will see a Handout section adjacent to Lessons. You can download the handouts from here.

Hope it helps!

If you have any other query then please feel free to get back to us.

Happy Learning :slight_smile:

Shubham Ranjan
Curriculum Support Engineer

yes it is there now - as per your screen shot - thank you.
However I do want to point out that directly beneath the lesson video - is also a tab for hand outs; and in this location it still does not appear…I think - though am not sure - that it should, but I could foresee students looking in this area first since we are oriented to the videos…

Hi @James_58604,

Thanks for surfacing this. We will add the zip file beneath the video lecture as well very soon.

Shubham Ranjan
Curriculum Support Engineer

i cannot find the zip file either-- i’ve looked at each section in chapter 0 and none of the sections have a “handouts” tab under the chapter dropdown as in the image above. am i looking in the wrong place?
also, none of the chapter 0 sections have a video named “m103 Vagrant Environment Setup” as in the image above. there’s only one video in the whole chapter, and it’s in the first section, titled “M103 Introduction to Replication and Sharding”.

i also have no lab in chapter 0 as referenced in the link above.

Please show your course screenshot
It should be there under handouts.Try to expand your course details with drop down button for chapter details

Same here. The first video doesn’t mention anything about the vagrant setup. There are also no handouts for Chapter 0.

Seems the course content has changed since December 2019.

you do not need vagrant

hi, here is a screenshot.

As Steeve mentioned you don’t need Vagrant for the new version of course

The previous snapshot by @James_58604 must be from old course

Does your latest course discuss anything about Vagrant?

Hi @Jeff_Stevens,

In the new IDE course, you don’t need to set up the Vagrant virtual machine on your system.

We are in the process of updating the video lectures to cut out those parts which says you will have to use vagrant. The changes will be out soon.

~ Shubham

that’s too bad-- there is a LOT of content that is better learned by being able to follow along and perform in a real mongodb instance.
thanks for the follow-up!

Hi @Jeff_Stevens,

Thanks for the feedback. You can also do all these things in the IDE environment. It has MongoDB Server installed on it.

Have you tried doing it ? If yes, then did you face any difficulty in doing so ?


since i posted that comment (“it’s too bad…”) i’ve been doing all of my following along in my free atlas cluster. that works great! don’t need the vagrant VM at all, and i can get to it with the shell or with compass.

trying to follow along with lectures using the IDE has some drawbacks:

  • it seems to only be available during labs. how do you get to the IDE during a video lecture?
  • it’s a little laggy-- even though i’ve got a mac laptop that is plenty fast
  • you can’t size it up-- there’s way too little info shown in each window
  • if you have any trouble with your browser or page, you lose the IDE and have to start over
  • it’s configured a certain way for that lab and we can’t change the configuration

I’m in the lab “launching mongod” using the IDE terminal that is given in the page. When I give the simple command to launch(mongod --port 27000) it is giving me an error. Can you please help . kindly Tell me what I am missing?

Hi @gowtham_Vuppaladhadiam,

You are running the command in the Editor space.

You are supposed to run this command in the terminal, which is the lower-most panel.

Please refer this post.

~ Shubham

Thanks. After typing the command, I pressed enter in terminal and then it worked.