Where I can I get cluster uri [Solved]

I want ti import mflix database but for this he is asking me for cluster URI

Hi @pruthviraj_44785

You can get your Cluster URI from the Atlas Cluster you setup in “Chapter 2: The MongoDB Query Language + Atlas - Lab 2.0: Create an Atlas Sandbox Cluster (Ungraded)”. There are helpful instructions on the Atlas Docs page on how to get the URI for your cluster.

You should complete those steps before moving to “Chapter 2: The MongoDB Query Language + Atlas - Loading Data into Your Sandbox Cluster”.

Hope this helps and please let me know if this resolves your issue.

1 Like

sorry sit, but not getting to connect
the bellow error is he throwing what can I do ?

Pruthvi-2:bin Pruthvi$ mongo “mongodb+srv://mflix-5xsxd.mongodb.net/test” --username m220student
MongoDB shell version v3.4.15
connecting to: mongodb://mongodb%2Bsrv:/%2Fmflix-5xsxd.mongodb.net%2Ftest
2019-03-21T20:00:46.389+0530 E QUERY [thread1] Error: No digits :
exception: connect failed
Pruthvi-2:bin Pruthvi$

this error is giving when importing database

Hi @pruthviraj_44785

It looks like your Atlas cluster is running 4.0.6 and the MongoDB Shell / Tools on your machine are running 3.4.15. I think the easiest thing to avoid these errors is to update your MongoDB Shell and Tools to 4.0.6. You can download the latest version from https://www.mongodb.com/download-center/.

Let me know if you have any issues when you upgrade to the latest version.


updated after this he is throwing error

mongorestore is a Windows/Linux command. You should call it while outside the mongo shell.

Hi @pruthviraj_44785

It looks like there are extra characters in the MFLIX_DB_URI setting your “.ini” file, specifically the “%2F” characters at the start and at the end. I’d suggest you try copy and pasting your cluster URI to MFLIX_DB_URI setting in your “.ini” file. This is documented in “Chapter 1: Driver Setup - README - Running the Application”.

Let me know if this works for you.

Kindest regards,

please tell me the logic what exactly I have to do in this task download the dump db and import to my compass or in my cluster ?

this is happening

Try putting quotes around the URI. Some shells interpret the plus sign.

not working

tried my best but not working

I have tried it on my mongo shell also

I suspect your mongorestore is an old version that does not support the srv connection string.

Verify your version and update if this is the case.

1 Like

yesssssss I have done it thank-you so much …

1 Like