Waiting until server is ready for connection

I am stuck here, waiting for server for almost 1 hour, I can’t log in and this is frustrating, how can I resolve this, please.

It hangs sometimes.

  1. Press Ctrl+C or Ctrl+D to come out of it
  2. Run kill -9 2363

Normally takes mere 2 or 3 seconds so if in the future it’s taking longer than a few seconds, just kill it and restart.

I have restarted it but is still the same.

I do not understand this…

Let’s see the following outputs:

  1. Screenshot of your config file
  2. ps -ef | grep [m]ongo


Config File

Inconsistent spacing in your config file and you don’t need the operationProfiling section.

Still same here, am getting tired of this issue.

Quoting same issue :arrow_up:

… it may not resolve the hangup, but it needs to be fixed to rule it out.

By the way, the config settings you’re using is a copy and paste from the lab?

Yes, is a copied config from LAB

Ok. engineConfig and cacheSizeGB have too many spaces. It should look like this

In addition, let’s see the following outputs:
ls -l /var/mongodb/db
ls -l /var/mongodb/db/4

I suspect this my issue could be because i did not shut the server down properly , but right i could even login to shut it down.

When i try to login , all i see is this…am just getting tired.

When did you not shut it down properly? And how?

You can’t login to a server that hasn’t been initiated.

How do you think I feel? :smile:

Back to the problem…

  1. From the first screenshot, you haven’t created the keyfile and there’s no folder called pki. This could very well be the culprit.
  2. if there’s a log file, look in there:
    tail -n 40 /var/mongodb/db/4/mongod.log
    cat /var/mongodb/db/4/mongod.log

On number 1: this pki file is in mongodb folder.

On running tail -n 40 /var/mongodb/db/4/mongod.log

Good point about pki. I was logged in from my phone so I must have missed it.

There are still unanswered questions/queries from previous posts:

In addition, run the mongod followed by the tail function.

Lastly tell me how much installed and used RAM you have.

NB: There are 4 questions/queries here. Please answer all.

On 1) after closing the spaces … i tried initiating the node and this error came up.


(2) On Saturday all those processes were working, but I left my system for a while later shut the system with everything running on it. It was when I came on Sunday to continue my work that this issue came up, I feel the nodes may somehow be working on the server , I do not know the script to run and check if any is running or to shut everything off just in case is running, I have tried using killall mongod but the issue is still on.

(3) Am not sure am using the tail function properly on mongod, please guide me with a line on how to run it.

engineConfig is an option under wiredTiger. It should be two spaces after wiredTiger, exactly like my screenshot (the yellow highlights are spaces). Fix and send me a screenshot. Also refer to the documentation.

The error you’re getting is because of what I just mentioned above. We must eliminate this error before we run tail.

Fourth question? If you’re not sure how, click on the Windows start menu > type RAM > click View Ram Info and you’ll see the installed and used ram info.

This is the config file now

On the RAM