Vt-x not supported on my cpu - windows 7

I installed vagrant 1.9.6 and virtualbox 5.1 as per the instructions for windows 7 64bit. My computer does not support vt-x which causes an error when trying to run: vagrant up … I think the issue is related to running a 64bit vm. Any thoughts from the staff? It’s not a matter of enabling it in the bios … it’s not supported at all.

It could mean that, unfortunately, your system is unsuitable.

What kind of CPU do you have I. There? And incidentally, how much RAM do you have?

Pentium® Dual-Core CPU T4300 @ 2.1GHz 4.00GB RAM 64-bit Win 7
HP-G60 laptop

I know from Intel’s web site that this processor does not support vt-x … despite the fact that the host OS is 64 bit it doesn’t like a 64-bit vm. I have the same issue with vmware although I can run 32-bit linux distros on it. I’m not sure if Virtualbox will support a 32-bit OS.

With all due respect and not meaning to sound rude or anything, but are you a staff member of mongodb university?

I’m a former Oracle DBA and have done a fair bit of Unix sys admin on various flavours.

I am not, though I fail to see how that is relevant on an open forum where students are there to help each other.

Now, you say Vagrant throws an error. Could you provide the literal error? A copy/paste would be fine.

Also, your initial assessment seems to be correct: while you can run VMs, you won’t be able to run 64-bit VMs. For M001 this isn’t much of a limitation, since you will only be using client software. In later courses however you will also run MongoDB server components, which only come in 64-bit compilations.

Even for M001 MongoU have opted to standardize towards to 64-bits systems as this covers the majority of their students’ systems. Unfortunately that leaves out a few edge cases, like your laptop. There have been a few other students with lighter Win7 laptops, but the majority of people are on full 64 bits with vt-x, hyper-threading etc.

1 Like

Hi @travis_03556,

Your system does not seem compatible for Vagrant. Here is one post, where some one solved the issue by installing latest version of Vagrant and upgrading powershell. Can you give it a try?

I used Win-7, Vagrant 1.9.6 and VirtualBox 5.2.16 at the beginning. The machine complained I need older version VirtualBox. Because I do not want to downgrade VirtualBox, I update Vagrant to 2.1.2. Meanwhile, I upgrade the windows PowerShell from 2 to 3. Everything worked.

Link: Vagrant Issues on Windows

Let me know if I can help with anything.


Unfortunately, one of the steps in that thread is going to fail: the one where they adjust hardware virt in BIOS. Their CPU does not support this.

It would still be interesting to see the error message though!

Work-around for M001 would be to install a 32-bit VM and find the old 32-bit shell installer. Was Compass ever compiles for 32-bit? An older version? I seem to recall a recent thread where someone had a similar situation…

Workaround for M103 would be to look into either other hardware or a free tier cloud solution, with the likes of AWS.

The issue is not with Vagrant … The problem is that Virtualbox requires vt-x to be supported on the machine. In my case it is not a matter of enabling it in the bios or turning off Hyper-V as referenced in the link you provided. vt-x is not supported by my CPU. Vagrant throws an error because it is running a Virtualbox cli command to get it to do something. The error is actually thrown by Virtualbox even though it shows up when running the vagrant up command. Thanks for your interest.

I realize that this is an open forum where students are here to help each other but I’m sure you realize that not all help is of equal value. In general when I search the Internet for technical solutions I’m often appalled at the poor quality of people’s suggestions. In my original post I was specifically asking for any thoughts from the staff. Don’t get me wrong, I do appreciate your response. Asking if you are staff is relevant because it is an attempt to vet your response. When I evaluate information I want to know if my source is reliable. Something I read in the National Inquirer is probably not as valuable as something I read in the Washington Post or New York Times.

I should clarify … I did not say that Vagrant throws an error … I said there was an error when running the ‘vagrant up’ command. The error is actually from Virtualbox which is being called with a cli command from the vagrant software. I’ve uninstalled both Vagrant and Virtualbox but the error was along the lines of (Stderr: VBoxManage.exe: error: VT-x is not available (VERR_VMX_NO_VMX) VBoxManage.exe:) which is similar to some other postings.

Your comment “Work-around for M001 would be to install a 32-bit VM and find the old 32-bit shell installer.” is interesting but lacks sufficient detail to be useful. As for looking into other hardware … duh.

What I really want is for a staff member to tell me unequivocally that I cannot participate in this course due to the vt-x limitation or offer some other solution.

Perhaps this discussion was not the place to request this information. For that I apologize.

You JUST spoke to a staff member: @Kanika.

Either way, I shall no longer hold you up. Best of luck to you.

Thanks for the info on @Kanika. You were right in identifying the problem with the link kanika provided. I think you understood my problem more clearly. It doesn’t look like I’m going to get the sort of answer I was hoping for from the staff. I’ll probably just watch the videos and see if it’s possible to set something up without using a virtual machine. I really do appreciate your help. I hope I didn’t offend (although I probably did). Best regards.

I’m curious what kind of answer you were hoping to get.

To sum it up, with regards to the labs:

  • M103 focuses on running multiple MongoD processes on a system of your own.
  • MongoD is not currently available in 32-bit compilations.
  • The labs use validation scripts and binaries to confirm whether you have passed an exercise. These tools are part of the MongoU-provided VMs.

So while you could run a 32-bit OS in a VM, you wouldn’t be able to follow along on the labs (because you’d lack MongoD).

You can of course, as you point out, follow all the videos. But you wouldn’t be able to do the labs.

Hi @travis_03556,

What I really want is for a staff member to tell me unequivocally that I cannot participate in this course due to the vt-x limitation or offer some other solution.

@Kanika is a member of MongoDB University staff. So any reply from Kanika is a reply from a staff member.

Something I read in the National Inquirer is probably not as valuable as something I read in the Washington Post or New York Times.

Not sure this analogy plays well here. This is not a medium to share/get the town gossip. Is a free forum that your fellow course attendees use to get help from staff and from other experienced students, like @Tess_Sluijter that is an amazing colleague, super helpful towards others, that has taken most courses and has lots of “war scars” fixing issues and contributing back with great feedback.
Forum etiquette is appreciated towards everyone that is participating.

To your question at hand.
If the issue is related with not being able to boot in a 64bit machine Virtualbox, you can still complete the course as long as you have installed Ubuntu 14.04 and run the m103-vagrant-env/provision-mongod script locally.
This is a native workaround, that will install several different packages in your system, including all the necessary dependencies to run MongoDB and the validation scripts.
If you are ok with that, the process that you should take is the following:

  • Install ubuntu 14.04 locally
  • Download the course handouts
  • Run the provision script provision-mongod
  • Configure your workstation with ip address

Once you have all of these steps configured you should be able to complete the course labs.

Sorry for any frustration that this setup may have caused but there is no need to dismiss others advice just because they might not seem to be what you are looking for!



I assume that, in this case, you mean actually booting the physical machine into Ubuntu, right? Yeah, that makes sense.

Huh, stupid that I didn’t think of that! @travis_03556 could of course just install Ubu on a temporary, external drive and work from there. Assuming that they really have to use this specific laptop and don’t have a spare piece of kit lying around. Not everyone has the luxury of having a full homelab.


Correct. At the end, the VM is an ubuntu box. It just happens to run in isolation in your localhost.

Dual boot systems can also do the trick here. Again, this is a workaround to overcome hardware restrictions.



My sincere apologies to all involved in this discussion. In future I will be more careful in how I express myself. I understand my options now and thank everyone for their input.