Validate_m320 --version

Hi All,

when I try to run

validate_m320 --version

on my mac, I get the error

command not found: validate_m320

I have successfully changed the permissions:

-r-xr-xr-x@ 1 mkumar staff 12254081 Oct 1 11:45 validate_m320

Can someone please help?

Thanks

According to the lesson, this is how you run the validator executable in MacOS:

In addition, --version is an invalid option.

1 Like

Hi 007_jb,

Thanks for responding.

I was just trying to check the version first.
I also tried to run the command you mentioned

./validate_m320 example --file answer_schema.json

I get: exec format error: ./validate_m320

My only guess is that the validator file is not compatible with your OS. Try downloading the MacOS validator file again.

Yeah, Tried that multiple times and for every environment file. I initially suspected that links may have been corrupted and maybe pointing to the wrong files. But no luck so far :frowning:

Strange!

Silly question, but this is definitely the file you downloaded?
image

It looks like it’s only the Curriculum Engineers who can help.

yes, it is the file. It is really weird. Not sure what is going on with my machine.
I hope curriculum engineers notice it soon. Thanks for your help, though.

Another silly question… are you sure it’s a MacOS you’re using or a Linux? :slight_smile:

:rofl: it is macOS for sure

:joy: Great!!! :grin:

It worked after I restarted my machine :thinking: Not sure what happened.

Good to hear!!! :+1:

Put this line below in .bash_profile file
export PATH=<put the path to validate_m320 file here>:$PATH
Update the file
source .bash_profile
Now the command validate_m320 will run

1 Like

hi

I am facing issues in installing validate_m320 …do we have any other options?

@Sujaya_51648 please share a screenshot. And indicate which OS you’re using.

I could download this properly but not able to execute. May be due to company security restrictions. So, looking forward to know if there is any other alternative

:grey_question: :question:

image

My office laptop has Windows (64 bit). As this is from unknown publisher, it’s not allowing it to run
My home laptop has 32 bit windows

Have a chat with your IT department, they might be willing to allow this.

This is regarding 64 bit. I just had a chat with our IT department. They said that the exe is not running properly… not privilege issue
This is flashing once and not getting installed. Can I get the installer as attached?