Validate_lab_launch_mongod

I am getting this response. Don’t know what to do?

vagrant@m103:~$ validate_lab_launch_mongod
Client experienced a timeout when connecting to the database - check that mongod is running on the correct port, and that your user was created with the correct settings.

mongod is running on this PID

mongod 3904 vagrant 12u IPv4 19749 0t0 TCP 192.168.103.100:27000 (LISTEN)

Created user as like this:-

mongo admin --host 192.168.103.100:27000 --eval ’
db.createUser({
user: “m103-admin”,
pwd: “m103-pass”,
roles: [
{role: “root”, db: “admin”}
]
})

You might be missing the following requirement:

listens to connections from the IP address 192.168.103.100 and localhost

The localhost part.

The output of

ss -tlnp
ps -aef | grep [m]ongo

would be useful.

I am doing like this. Can you tell me how i will bind localhost in below command.

mongod --port 27000 --bind_ip 192.168.103.100 --dbpath /data/db --logpath /data/log.log --fork

I tried bellow ways also

mongod --port 27000 --bind_ip 192.168.103.100, localhost --dbpath /data/db --logpath /data/log.log --fork

vagrant@m103:~$ ss -tlnp
State Recv-Q Send-Q Local Address:Port Peer Address:Port
LISTEN 0 128 :41519 :
LISTEN 0 128 :111 :
LISTEN 0 128 :22 :
LISTEN 0 128 192.168.103.100:27000 : users:((“mongod”,4625,12))
LISTEN 0 128 :::111 :::

LISTEN 0 128 :::22 :::

LISTEN 0 128 :::51007 :::

vagrant@m103:~$ ps -aef | grep [m]ongo

vagrant 4625 1 0 12:30 ? 00:00:02 mongod --port 27000 --bind_ip 192.168.103.100 --dbpath /data/db --logpath /data/log.log --fork

The space after the comma is most likely the culprit.

mongod --port 27000 --bind_ip 192.168.103.100,localhost --dbpath /data/db --logpath /data/log.log --fork

Ya it worked. Thank u for speedy response and interaction.

Closing this thread as the issue has been resolved.