On running the validate_lab_launch_mongod, i am getting the alert message
“You need to specify db path /data/db.”

I’ve used the command “mongod --port 27000 --dbpath first_mongod --logpath first_mongod/mongod.log --bind_ip ‘,localhost’ --fork”.

How to resolve this issue?


The message tells you that you must set dbpath to /data/db and yet you start mongod with --dbpath first_mongod. Which part is not clear?

oh missed that, it worked now after changing the dbpath.

I did all that was required but I am not able to find: validate_lab_launch_mongod

command I used :

mongod --port 27000 --dbpath /home/vagrant/data/db --logpath /home/vagrant/data/db/mongod.log --bind_ip ‘,localhost’ --fork

@Manoj_92667, do you also get the error message ’ You need to specify db path /data/db’?

If you do, why don’t you try to do what the message tells you. That is specify db path to /data/db rather than /home/vagrant/data/db.

1 Like

You have probably entered the wrong lab and are running the wrong script. Maybe you’re running the script that corresponds to the configuration of the .conf file. Re-read the lab you’re in.

I am getting following error:

MongoDB Enterprise > validate_lab_launch_mongod
2019-01-14T10:55:24.904+0000 E QUERY [thread1] ReferenceError: validate_lab_launch_mongod is not defined :

validate_lab_launch_mongod is a command you enter at the vagrant prompt.

Thanks, it worked for me