Validate_lab_launch_mongod gives no output

Here is my config file :

[Removed some content]

vagrant@m103:/$ mongo admin --host localhost:27000 --eval ’

user: “m103-admin”,
pwd: “m103-pass”,
roles: [
{role: “root”, db: “admin”}

MongoDB shell version v3.6.16
connecting to: mongodb://localhost:27000/admin?gssapiServiceName=mongodb
Implicit session: session { “id” : UUID(“3f8bb012-3611-487e-ba77-a7eadfde255b”) }
MongoDB server version: 3.6.16
Successfully added user: {
“user” : “m103-admin”,
“roles” : [
“role” : “root”,
“db” : “admin”

After which if i run validate_lab_launch_mongod i dont get any output and there is no delay for me in getting the prompt like below

vagrant@m103:/ validate_lab_launch_mongod vagrant@m103:/

Hi @Aniket_69449,

Couple of things here :

  1. Please refrain from posting answers or information which will lead to answer in the forum until or unless one of the Curriculum Services Engineer asks you to do so for the debugging purpose. I have edited your post to remove the content of the configuration file.

  2. In this lab you are required to launch mongod using command line arguments and not using configuration file.

For further instruction on how to use command line options with mongod please refer our documentation.

Hope it helps!

Shubham Ranjan
Curriculum Services Engineer

Hi Shubham,

I am not getting any output after running validate_lab_launch_mongod
Rather i am not getting any output for any of the validate_lab* commands
Can you please help with that.

Please paste the snapshot
You should get some message or error


First is to try and re-provision the machine by running:
vagrant provision

If the validator is still not running then try a reload:
vagrant reload

And if you’re still having no joy then destroy and up the machine:
vagrant destroy -f
vagrant up

1 Like

Hi @Aniket_69449,

Follow these steps and it should resolve your issue. Please feel free to get back to us, if are still facing any issue.

Shubham Ranjan
Curriculum Services Engineer