Validate_lab_launch_mongod Client time out

vagrant@m103:~$ validate_lab_launch_mongod
Client experienced a timeout when connecting to the database - check that mongod is running on the correct port, and that your user was created with the correct settings.

vagrant@m103:~$ ps -ef | grep mongod
vagrant 2832 2694 1 02:56 pts/0 00:00:06 mongod --port 27000
vagrant 2879 2810 0 03:04 pts/2 00:00:00 grep --color=auto mongod

You haven’t met all the requirements yet:

Hi @James_58604,

As @007_jb has mentioned, please make sure you have included all the options which are required in this Lab.

If in case you need any assistance with it then please refer our documentation on mongod.

Hope it helps!

Happy Learning :slight_smile:

Shubham Ranjan
Curriculum Support Engineer

note that I have rebooted since last post - and will probably reboot again before next session…
I believe Vagrant, MinGW, and VirtualBox are all installed ok (I entered/passed the Vagrant validation key)
here is my sequence:
I cd to …\m103\m103-vagrant-env prompt

vagrant up - - - [at this point it is unclear if one must --provision each time (after a reboot)??]
vagrant ssh
“>vagrant@m103:~$” prompt

mongod --port 27000
[return at top: pid=3331 port=27000 dbpath=/data/db 64-bit host=m103]
[return at bottom: waiting for connections on port 27000]
– no echo – open 2nd command prompt
navigate to “>vagrant@m103:~$” prompt
mongo --port 27000

[ return successful but has several WARNING
* Using the XFS filesystem is strongly recommended with the WiredTiger storage engine
* Access control is not enabled for the database.
* This server is bound to localhost.
*/sys/kernel/mm/transparent_hugepage/enabled is ‘always’.]

“>MondoDB Enterprise prompt”

show dbs
[return: admin, config, local] (yesterday I did try to add user…so not sure if that is the config…)

so far so good

following class instructions to start a mondod --port 27000
data/db is a default

There is no instruction in the video or lesson to this point on IP bind; so one would assume this is a default too…there is a lot of outside documentation on IP binding - but the syntax is confusing (v4/6) I hope we’re not expected to perform this without any instruction - that would be discouraging…

and then yesterday tried to set the 1st authenticated user - which returned an error but also said it was successful - it was confusing tried to self diagnose based on past q/a strings

I see no instruction on how to verify the added user as correct / or whether it is an issue of authentication

“MongoDB Enterprise >” show users
“_id” : “test.m103-admin”,
“userId” : UUID(“5a420689-efb5-456d-b0fa-10d433da7da7”),
“user” : “m103-admin”,
“db” : “test”,
“roles” : [
“role” : “root”,
“db” : “admin”

exit the mongo shell back to
“vagrant@m103:~$” prompt
continue to get the ‘Client experienced a timeout’

in the post: [Errors while validating Creating First Application User] April 14 - - the dialog discusses a Config File - - but there has been no instruction on this method at all in the lessons - - -so not sure really what’s going on…

I am also facing same issue
when I tried to bind IP it starts mongod process but then could not open with 27000 port as mongod process is already running . Please help Admin

Find the mongod process and kill it or shut it down. How to do this was discussed in the mongod lecture.