Validate_box command not found

Im facing error while running validate_box command. Im connected to vagrant secured shell, version is 1.9

HI nehawadhawa,


  • For first lab: Lab: Setting up the Vagrant Environment , you need to run validate command from your vagrant box i.e after you have ssh into you vagrant (after 7th point) like:

vagrant@m103:~$ validate_box

  • If by any chance, above command results into error like:

vagrant@m103:~$ validate_box

validate_box: command not found

Run below command from your vagrant box like:

vagrant@m103:~$ download_validators

It will download the required validation scripts. If by any bad luck, that too don’t work, re provision vagrant from Point 5 to 7. If it still don’t work, then don’t hesitate to post on discussion forum.The validation scripts need to be run from outside the mongo shell but in the vagrant box, it won’t work from your local machine.

Need to Enter Password Again and Again for Vagrant ?? Solution:

If you are working with PuTTy and everytime you enter vagrant, it asks for your password, please try the following solution which worked for one user:

  1. Open the PuTTYgen utility;
  2. Click on the Load button;
  3. open the private_key file under the VM directory structure
  4. change the value in the Number of bits in a generated key: field to 2048 , leave everything else as it is
  5. Save the file as private.ppk
  6. Use this private.ppk file as the ‘private key file for authentication’ in PuTTy session config
  7. All works fine

Source :

Still, if you have problems setting up your vagrant, please don’t hesitate to post here!

Thanks for your reply kanika,

Im still facing issue. download_validators gives error as below


Followed steps again and error is still same.

Hi nehawadhawa,

Have you tried re-provisioning you vagrant? DO it using:

vagrant up --provision

Let me know if it works!


Me parece que es por esto.

Podrias indicar donde cambiar la configuración

Hi Luis_Alberto_59896,

Are you facing any issue in running vagrant?

If not, then please share how you resolved this problem.


Hi guys, could you help me with problem “validate_box”?
I’ve tried re-run ‘vagrant up --provision’ but the problem still stay.
Last login: Tue Nov 20 17:37:16 2018 from
vagrant@vagrant-ubuntu-trusty-64:~ validate_box validate_box: command not found vagrant@vagrant-ubuntu-trusty-64:~ download_validators
download_validators: command not found

Hi Tsar36,

Please, re-provision the vagrant. Exit the vagrant and run:

vagrant provision

If that also does not solve your problem, then please download and copy validation files to your shared directory. Here is the post.


1 Like

Thanks! It working after ‘vagrant provision’ one more time and vagrant reboot.
Have a nice day! :slight_smile:

I have the same problem.
Get the same output if run download_validators and validate_box
If I run either vagrant up --provision or vagrant provision this is the output:

Hi Antonio_79832,

Can you please try this and let me know if it does not work.


I’ve done it. After copying the files in the shared directory is it supposed to run the command validate_box ? Or i have to do something else?

Right now I’m having the same issue. (The command is not found)

EDIT: I don’t know how but now it’s working. Thank you anyway

i downloaded and copied the validation files to shared folder but im still getting the same error on validate_box
command not found

meanwhile its telling me 2 packages needs to be can i update

Hi Chika_Echezona_19812,

You don’t need to copy the files. Three ways to try:

  • Run following command from vagrant:

    vagrant@m103:~$ download_validators
  • If above do not work, then run below command after exiting the vagrant:

    ~$ vagrant provision
  • If above also do not work, then copy the files to the /shared directory and run:

    vagrant@m103:~$ cd /shared
    vagrant@m103:/shared$ ./validate_box

If nothing works, from the last step, share the files in the directory and the ouput.


This command “download_validators” did not work even after a couple of provisions…
Downloaded the files => moved to the VM => added to the PATH variable in .profile => and now it’s ok.

1 Like