Vagrant / Virtualbox troubleshooting

For me, Vagrant has been a stopper for this course. In the spirit of ‘grit’ and helping the community, I will make an earnest effort to troubleshoot, and document, my struggles here. Hopefully, there will be success, but even if not, I think this should be helpful to others. I will also implement a strict “no whining” policy for myself! Sometimes whining will defeat a task before it’s even started!

First, the environment:

System: Dell XPS 9550 (laptop)
Type: 64-bit, x64-based processor
CPU: Intel(R) Core(TM) i7-6700HQ CPU @ 2.60GHz
RAM: 16.0 GB (15.9 GB usable)
OS: Windows 10 Pro version 1809

VirtualBox 6.04 r128413
Vagrant 2.2.3

Second, the problem. When following directions, the terminal outputs this:

> vagrant up
Bringing machine 'mongod-m103' up with 'virtualbox' provider...
==> mongod-m103: Importing base box 'ubuntu/trusty64'...
==> mongod-m103: Matching MAC address for NAT networking...
==> mongod-m103: Checking if box 'ubuntu/trusty64' version '20190108.0.0' is up to date...==> mongod-m103: Setting the name of the VM: mongod-m103
==> mongod-m103: Clearing any previously set forwarded ports...
==> mongod-m103: Fixed port collision for 22 => 2222. Now on port 2200.
==> mongod-m103: Clearing any previously set network interfaces...
==> mongod-m103: Preparing network interfaces based on configuration...
    mongod-m103: Adapter 1: nat
    mongod-m103: Adapter 2: hostonly
==> mongod-m103: Forwarding ports...
    mongod-m103: 22 (guest) => 2200 (host) (adapter 1)
==> mongod-m103: Running 'pre-boot' VM customizations...
==> mongod-m103: Booting VM...
==> mongod-m103: Waiting for machine to boot. This may take a few minutes...
    mongod-m103: SSH address:
    mongod-m103: SSH username: vagrant
    mongod-m103: SSH auth method: private key

Vagrant then hangs for awhile, and then times out with this message:

Timed out while waiting for the machine to boot. This means that
Vagrant was unable to communicate with the guest machine within
the configured ("config.vm.boot_timeout" value) time period.

If you look above, you should be able to see the error(s) that
Vagrant had when attempting to connect to the machine. These errors
are usually good hints as to what may be wrong.

If you're using a custom box, make sure that networking is properly
working and you're able to connect to the machine. It is a common
problem that networking isn't setup properly in these boxes.
Verify that authentication configurations are also setup properly,
as well.

If the box appears to be booting properly, you may want to increase
the timeout ("config.vm.boot_timeout") value.

That’s a statement of the problem. I’ll describe the steps I go through in posts below. Suggestions welcome!

There are a few things I have tried already, and briefly what happened:

  • increase the timeout as suggested in the terminal output: no change, just longer timeout
  • vagrant up --debug: vagrant is not getting a response from the vm
  • use an admin account (by default, I use a non-admin account and require permissions each time): no change, same result
  • in a new directory: vagrant init "ubuntu/trusty64" then vagrant up: same result, so it is not the M103 course Vagrantfile. I’m thinking likely Virtualbox itself. Can I get a virtual machine running at all?

When virtualbox hangs and I open the GUI, if I click on a button the represents a running virtual machine, Virtualbox itself becomes unresponsive. I have to kill it using Task Manager (‘VBoxHeadless.exe’) before Virtualbox is responsive again. These are the logs for the vanilla ubuntu/trusty64 OS I initted as a final step, above (please forgive the spam)

00:00:00.620097 VirtualBox VM 6.0.4 r128413 win.amd64 (Jan 25 2019 18:13:23) release log
00:00:00.620133 Log opened 2019-02-13T10:32:02.807736800Z
00:00:00.620134 Build Type: release
00:00:00.620143 OS Product: Windows 10
00:00:00.620144 OS Release: 10.0.17763
00:00:00.620146 OS Service Pack: 
00:00:00.719593 DMI Product Name: XPS 15 9550
00:00:00.726922 DMI Product Version: 
00:00:00.726945 Host RAM: 16245MB (15.8GB) total, 8331MB (8.1GB) available
00:00:00.726951 Executable: C:\Program Files\Oracle\VirtualBox\VBoxHeadless.exe
00:00:00.726952 Process ID: 8196
00:00:00.726953 Package type: WINDOWS_64BITS_GENERIC
00:00:00.728769 Installed Extension Packs:
00:00:00.728842   None installed!
00:00:00.730132 Console: Machine state changed to 'Starting'
00:00:00.907232 SUP: Loaded VMMR0.r0 (C:\Program Files\Oracle\VirtualBox\VMMR0.r0) at 0xXXXXXXXXXXXXXXXX - ModuleInit at XXXXXXXXXXXXXXXX and ModuleTerm at XXXXXXXXXXXXXXXX using the native ring-0 loader
00:00:00.907295 SUP: VMMR0EntryEx located at XXXXXXXXXXXXXXXX and VMMR0EntryFast at XXXXXXXXXXXXXXXX
00:00:00.907308 SUP: windbg> .reload /f C:\Program Files\Oracle\VirtualBox\VMMR0.r0=0xXXXXXXXXXXXXXXXX
00:00:00.915700 Guest OS type: 'Ubuntu_64'
00:00:00.917958 fHMForced=true - 64-bit guest
00:00:00.924524 File system of 'C:\Users\renda\VirtualBox VMs\vagrant_default_1550053914662_68028\Snapshots' (snapshots) is unknown
00:00:00.924542 File system of 'C:\Users\renda\VirtualBox VMs\ubuntu-cloudimg-trusty-vagrant-amd64\box-disk1_2.vmdk' is ntfs
00:00:00.947070 Shared clipboard service loaded
00:00:00.947090 Shared clipboard mode: Off
00:00:00.961816 Drag and drop service loaded
00:00:00.961838 Drag and drop mode: Off
00:00:02.072111 Per-VM extradata API settings:
00:00:02.072150   VBoxInternal2/SharedFoldersEnableSymlinksCreate/vagrant="1"
00:00:02.072922 ************************* CFGM dump *************************
... skipped to fit inside the post character limit ...
00:00:02.073851 ********************* End of CFGM dump **********************
00:00:02.073907 VM: fHMEnabled=true  (configured) fRecompileUser=false fRecompileSupervisor=false
00:00:02.073909 VM: fRawRing1Enabled=false CSAM=true  PATM=true 
00:00:02.074306 HM: HMR3Init: Attempting fall back to NEM: VT-x is not available
00:00:02.193690 NEM: WHvCapabilityCodeHypervisorPresent is TRUE, so this might work...
00:00:02.193727 NEM: WHvCapabilityCodeExtendedVmExits      = 0x0000000000000007
00:00:02.193739 NEM:                       fExtendedMsrExit: 1
00:00:02.193749 NEM:                     fExtendedCpuIdExit: 1
00:00:02.193757 NEM:                      fExtendedXcptExit: 1
00:00:02.193766 NEM: Warning! Unknown feature definitions: 0x1f
00:00:02.193809 NEM: Supported exception exit bitmap: 0x1
00:00:02.193846 NEM: WHvCapabilityCodeProcessorVendor      = 1 - Intel
00:00:02.193885 NEM: WHvCapabilityCodeProcessorFeatures    = 0x000178ffe7f7859f
00:00:02.193925 NEM:                            Sse3Support: 1
00:00:02.193935 NEM:                        LahfSahfSupport: 1
00:00:02.193944 NEM:                           Ssse3Support: 1
00:00:02.193952 NEM:                          Sse4_1Support: 1
00:00:02.193961 NEM:                          Sse4_2Support: 1
00:00:02.193969 NEM:                           Sse4aSupport: 0
00:00:02.193977 NEM:                             XopSupport: 0
00:00:02.193986 NEM:                          PopCntSupport: 1
00:00:02.193994 NEM:                      Cmpxchg16bSupport: 1
00:00:02.194003 NEM:                       Altmovcr8Support: 0
00:00:02.194011 NEM:                           LzcntSupport: 1
00:00:02.194020 NEM:                     MisAlignSseSupport: 0
00:00:02.194028 NEM:                          MmxExtSupport: 0
00:00:02.194036 NEM:                        Amd3DNowSupport: 0
00:00:02.194045 NEM:                ExtendedAmd3DNowSupport: 0
00:00:02.194053 NEM:                         Page1GbSupport: 1
00:00:02.194062 NEM:                             AesSupport: 1
00:00:02.194070 NEM:                       PclmulqdqSupport: 1
00:00:02.194079 NEM:                            PcidSupport: 1
00:00:02.194087 NEM:                            Fma4Support: 0
00:00:02.194096 NEM:                            F16CSupport: 1
00:00:02.194104 NEM:                          RdRandSupport: 1
00:00:02.194112 NEM:                        RdWrFsGsSupport: 1
00:00:02.194121 NEM:                            SmepSupport: 1
00:00:02.194129 NEM:              EnhancedFastStringSupport: 1
00:00:02.194146 NEM:                            Bmi1Support: 1
00:00:02.194155 NEM:                            Bmi2Support: 1
00:00:02.194235 NEM:                           MovbeSupport: 1
00:00:02.194248 NEM:                          Npiep1Support: 1
00:00:02.194257 NEM:                   DepX87FPUSaveSupport: 1
00:00:02.194265 NEM:                          RdSeedSupport: 1
00:00:02.194274 NEM:                             AdxSupport: 1
00:00:02.194282 NEM:                   IntelPrefetchSupport: 1
00:00:02.194290 NEM:                            SmapSupport: 1
00:00:02.194299 NEM:                             HleSupport: 1
00:00:02.194307 NEM:                             RtmSupport: 1
00:00:02.194316 NEM:                          RdtscpSupport: 1
00:00:02.194324 NEM:                      ClflushoptSupport: 1
00:00:02.194333 NEM:                            ClwbSupport: 0
00:00:02.194341 NEM:                             ShaSupport: 0
00:00:02.194350 NEM:                X87PointersSavedSupport: 0
00:00:02.194358 NEM: Warning! Unknown CPU features: 0x178ffe7f7859f
00:00:02.194405 NEM: WHvCapabilityCodeProcessorClFlushSize = 2^8
00:00:02.195685 NEM: Warning! Unknown capability 0x1003 returning: 3f 38 00 00 00 00 00 00
00:00:02.197143 NEM: VidGetHvPartitionId            -> fun:0x2210a7 in:0x0 out:0x8
00:00:02.197163 NEM: VidStartVirtualProcessor       -> fun:0x22116c in:0x4 out:0x0
00:00:02.197182 NEM: VidStopVirtualProcessor        -> fun:0x221178 in:0x4 out:0x0
00:00:02.197202 NEM: VidMessageSlotHandleAndGetNext -> fun:0x2210d7 in:0x8 out:0x0
00:00:02.197314 NEM: Created partition 0000000001112150.
00:00:02.197540 NEM: NEMR3Init: Active.
00:00:02.197711 MM: cbHyperHeap=0x100000 (1048576)
00:00:02.200562 CPUM: No hardware-virtualization capability detected
00:00:02.207638 CPUM: fXStateHostMask=0x7; initial: 0x7; host XCR0=0x1f
00:00:02.216240 CPUM: Matched host CPU INTEL 0x6/0x5e/0x3 Intel_Core7_Skylake with CPU DB entry 'Intel Core i7-6700K' (INTEL 0x6/0x5e/0x3 Intel_Core7_Skylake)
00:00:02.216557 CPUM: MXCSR_MASK=0xffff (host: 0xffff)
00:00:02.216644 CPUM: Microcode revision 0x000000C6
00:00:02.216740 CPUM: MSR/CPUID reconciliation insert: 0x0000010b IA32_FLUSH_CMD
00:00:02.216845 CPUM: SetGuestCpuIdFeature: Enabled SYSENTER/EXIT
00:00:02.216856 CPUM: SetGuestCpuIdFeature: Enabled SYSCALL/RET
00:00:02.216865 CPUM: SetGuestCpuIdFeature: Enabled PAE
00:00:02.216873 CPUM: SetGuestCpuIdFeature: Enabled LONG MODE
00:00:02.216881 CPUM: SetGuestCpuIdFeature: Enabled LAHF/SAHF
00:00:02.216890 CPUM: SetGuestCpuIdFeature: Enabled NX
00:00:02.219037 NEM: Successfully set up partition (device handle 0000000000000a90, partition ID 0x3)
00:00:02.219065 NEM: Memory balance: 0xea out of 0x116 pages in use
00:00:02.221590 PGM: HCPhysInterPD=00000000392c1000 HCPhysInterPaePDPT=00000000392c4000 HCPhysInterPaePML4=00000000392aa000
00:00:02.221611 PGM: apInterPTs={00000000392c2000,00000000392c3000} apInterPaePTs={000000047eec7000,000000047eec8000} apInterPaePDs={000000047eec9000,000000047eeca000,000000047eecb000,000000047eecc000} pInterPaePDPT64=00000000392a9000
00:00:02.221626 PGM: Host paging mode: AMD64+NX
00:00:02.221693 PGM: PGMPool: cMaxPages=288 (u64MaxPages=288)
00:00:02.221703 PGM: pgmR3PoolInit: cMaxPages=0x120 cMaxUsers=0x240 cMaxPhysExts=0x240 fCacheEnable=true 
00:00:02.241352 TM: GIP - u32Mode=3 (Invariant) u32UpdateHz=93 u32UpdateIntervalNS=10741500 enmUseTscDelta=2 (Practically Zero) fGetGipCpu=0xb cCpus=8
00:00:02.241414 TM: GIP - u64CpuHz=2 591 998 078 (0x9a7ec07e)  SUPGetCpuHzFromGip => 2 591 998 078
00:00:02.241428 TM: GIP - CPU: iCpuSet=0x0 idCpu=0x0 idApic=0x0 iGipCpu=0x0 i64TSCDelta=0 enmState=3 u64CpuHz=2591998078(*) cErrors=0
00:00:02.241440 TM: GIP - CPU: iCpuSet=0x1 idCpu=0x1 idApic=0x1 iGipCpu=0x2 i64TSCDelta=0 enmState=3 u64CpuHz=2591996967(*) cErrors=0
00:00:02.241450 TM: GIP - CPU: iCpuSet=0x2 idCpu=0x2 idApic=0x2 iGipCpu=0x1 i64TSCDelta=0 enmState=3 u64CpuHz=2591919385(*) cErrors=0
00:00:02.241460 TM: GIP - CPU: iCpuSet=0x3 idCpu=0x3 idApic=0x3 iGipCpu=0x6 i64TSCDelta=0 enmState=3 u64CpuHz=2591998027(*) cErrors=0
00:00:02.241469 TM: GIP - CPU: iCpuSet=0x4 idCpu=0x4 idApic=0x4 iGipCpu=0x3 i64TSCDelta=0 enmState=3 u64CpuHz=2591997848(*) cErrors=0
00:00:02.241482 TM: GIP - CPU: iCpuSet=0x5 idCpu=0x5 idApic=0x5 iGipCpu=0x5 i64TSCDelta=0 enmState=3 u64CpuHz=2591998021(*) cErrors=0
00:00:02.241494 TM: GIP - CPU: iCpuSet=0x6 idCpu=0x6 idApic=0x6 iGipCpu=0x4 i64TSCDelta=0 enmState=3 u64CpuHz=2591998025(*) cErrors=0
00:00:02.241503 TM: GIP - CPU: iCpuSet=0x7 idCpu=0x7 idApic=0x7 iGipCpu=0x7 i64TSCDelta=0 enmState=3 u64CpuHz=2591997843(*) cErrors=0
00:00:02.241572 TM: NEM overrides the /TM/TSCModeSwitchAllowed setting.
00:00:02.241614 TM: cTSCTicksPerSecond=2 591 998 078 (0x9a7ec07e) enmTSCMode=4 (NativeApi)
00:00:02.241617 TM: TSCTiedToExecution=false TSCNotTiedToHalt=false
00:00:02.242837 VMM: CoreCode: R3=0000000004620000 R0=XXXXXXXXXXXXXXXX RC=a035b000 Phys=00000000392a4000 cb=0x1000
00:00:02.243869 EMR3Init: fRecompileUser=false fRecompileSupervisor=false fRawRing1Enabled=false fIemExecutesAll=false fGuruOnTripleFault=true 
00:00:02.244506 IEM: TargetCpu=CURRENT, Microarch=Intel_Core7_Skylake
00:00:02.245262 GIM: Using provider 'None' (Implementation version: 0)
00:00:02.245519 AIOMgr: Default manager type is 'Async'
00:00:02.245556 AIOMgr: Default file backend is 'NonBuffered'
00:00:02.246230 BlkCache: Cache successfully initialized. Cache size is 5242880 bytes
00:00:02.246248 BlkCache: Cache commit interval is 10000 ms
00:00:02.246257 BlkCache: Cache commit threshold is 2621440 bytes
00:00:02.679749 PcBios: [SMP] BIOS with 1 CPUs
00:00:02.679908 PcBios: Using the 386+ BIOS image.
00:00:02.686020 PcBios: MPS table at 000e1300
00:00:02.687061 PcBios: fCheckShutdownStatusForSoftReset=true   fClearShutdownStatusOnHardReset=true 
00:00:02.712712 SUP: Loaded VBoxDDR0.r0 (C:\Program Files\Oracle\VirtualBox\VBoxDDR0.r0) at 0xXXXXXXXXXXXXXXXX - ModuleInit at XXXXXXXXXXXXXXXX and ModuleTerm at XXXXXXXXXXXXXXXX using the native ring-0 loader
00:00:02.712736 SUP: windbg> .reload /f C:\Program Files\Oracle\VirtualBox\VBoxDDR0.r0=0xXXXXXXXXXXXXXXXX
00:00:02.713604 CPUM: SetGuestCpuIdFeature: Enabled xAPIC
00:00:02.714556 IOAPIC: Using implementation 2.0! Chipset type ICH9
00:00:02.714847 PIT: mode=3 count=0x10000 (65536) - 18.20 Hz (ch=0)
00:00:02.740255 Shared Folders service loaded
00:00:02.754578 Guest Control service loaded
00:00:02.799414 VGA: Using the 386+ BIOS image.
00:00:02.807230 DrvVD: Flushes will be ignored
00:00:02.807251 DrvVD: Async flushes will be passed to the disk
00:00:02.812189 VD: VDInit finished with VINF_SUCCESS
00:00:02.822082 VD: Opening the disk took 10296631 ns
00:00:02.822340 AHCI: LUN#0: disk, PCHS=16383/16/63, total number of sectors 83886080
00:00:02.823036 AHCI#0: Reset the HBA
00:00:02.823053 VD#0: Cancelling all active requests
00:00:02.823254 E1000#0: Chip=82540EM LinkUpDelay=3000ms EthernetCRC=on GSO=enabled Itr=disabled ItrRx=enabled TID=disabled R0=enabled GC=enabled
00:00:02.858523 NAT: Guest address guess set to by initialization
00:00:02.904807 NAT: DNS#0:
00:00:02.988657 NAT: Failed to redirect TCP -> (Unknown error)
00:00:02.991293 PGM: The CPU physical address width is 39 bits
00:00:02.991314 PGM: PGMR3InitFinalize: 4 MB PSE mask 0000007fffffffff
00:00:02.991663 TM: TMR3InitFinalize: fTSCModeSwitchAllowed=false
00:00:02.992460 VMM: Thread-context hooks unavailable
00:00:02.992475 VMM: RTThreadPreemptIsPending() can be trusted
00:00:02.992484 VMM: Kernel preemption is possible
00:00:02.992536 EM: Exit history optimizations: enabled=true  enabled-r0=true  enabled-r0-no-preemption=false
00:00:02.992549 VMM: fUsePeriodicPreemptionTimers=false
00:00:02.992675 CPUM: Logical host processors: 8 present, 8 max, 8 online, online mask: 00000000000000ff
00:00:02.992678 CPUM: Physical host cores: 4
00:00:02.992679 ************************* CPUID dump ************************

... skipped to fit inside the post character limit ...

00:00:02.993894 ******************** End of CPUID dump **********************
00:00:02.994197 PcBios: SATA LUN#0 LCHS=1024/255/63
00:00:02.994335 APIC: fPostedIntrsEnabled=false fVirtApicRegsEnabled=false fSupportsTscDeadline=false
00:00:02.994353 TMR3UtcNow: nsNow=1 550 053 925 181 571 900 nsPrev=0 -> cNsDelta=1 550 053 925 181 571 900 (offLag=0 offVirtualSync=0 offVirtualSyncGivenUp=0, NowAgain=1 550 053 925 181 571 900)
00:00:02.994372 VMEmt: Halt method global1 (5)
00:00:02.994441 VMEmt: HaltedGlobal1 config: cNsSpinBlockThresholdCfg=50000
00:00:02.994452 Changing the VM state from 'CREATING' to 'CREATED'
00:00:02.996656 SharedFolders host service: Adding host mapping
00:00:02.996677     Host path '\\?\C:\workspace\experiments\vagrant', map name 'vagrant', writable, automount=false, automntpnt=, create_symlinks=true, missing=false
00:00:02.997001 Changing the VM state from 'CREATED' to 'POWERING_ON'
00:00:02.997747 Changing the VM state from 'POWERING_ON' to 'RUNNING'
00:00:02.997776 Console: Machine state changed to 'Running'
00:00:03.008292 VMMDev: Guest Log: BIOS: VirtualBox 6.0.4
00:00:03.008838 PCI: Setting up resources and interrupts
00:00:03.034641 PIT: mode=2 count=0x10000 (65536) - 18.20 Hz (ch=0)
00:00:03.101456 Display::handleDisplayResize: uScreenId=0 pvVRAM=0000000000000000 w=720 h=400 bpp=0 cbLine=0x0 flags=0x0
00:00:03.131162 VMMDev: Guest Log: CPUID EDX: 0x178bfbff
00:00:03.197286 AHCI#0: Reset the HBA
00:00:03.197325 VD#0: Cancelling all active requests
00:00:03.198702 AHCI#0: Port 0 reset
00:00:03.198926 VD#0: Cancelling all active requests
00:00:03.205839 VMMDev: Guest Log: BIOS: AHCI 0-P#0: PCHS=16383/16/63 LCHS=1024/255/63 0x0000000005000000 sectors
00:00:03.227873 PIT: mode=2 count=0x48d3 (18643) - 64.00 Hz (ch=0)
00:00:03.230282 Display::handleDisplayResize: uScreenId=0 pvVRAM=0000000006c90000 w=640 h=480 bpp=32 cbLine=0xA00 flags=0x0
00:00:05.712162 Display::handleDisplayResize: uScreenId=0 pvVRAM=0000000006c90000 w=640 h=480 bpp=0 cbLine=0x280 flags=0x0
00:00:05.735753 Display::handleDisplayResize: uScreenId=0 pvVRAM=0000000000000000 w=720 h=400 bpp=0 cbLine=0x0 flags=0x0
00:00:05.764937 PIT: mode=2 count=0x10000 (65536) - 18.20 Hz (ch=0)
00:00:05.767817 VMMDev: Guest Log: BIOS: Boot : bseqnr=1, bootseq=0002
00:00:05.772284 VMMDev: Guest Log: BIOS: Booting from Hard Disk...
00:00:12.318680 PIT: mode=2 count=0x12a5 (4773) - 249.98 Hz (ch=0)

I’m not sure how to read these logs. There are a few entries I note, but I do not know their significance:

00:00:02.193766 NEM: Warning! Unknown feature definitions: 0x1f
00:00:02.194358 NEM: Warning! Unknown CPU features: 0x178ffe7f7859f
00:00:02.195685 NEM: Warning! Unknown capability 0x1003 returning: 3f 38 00 00 00 00 00 00
00:00:02.988657 NAT: Failed to redirect TCP -> (Unknown error)

That last might be relevent. I’ll search to see.

Next I will try to install a Windows OS into VM and see if I can get Virtualbox running with that.

1 Like

There is a parallel strain of thought in my mind: that maybe I just abandon the whole idea of getting this running on Windows. I should have a Linux dual boot anyway, and maybe it would just be better to try again from a new OS. But, for the sake of ‘grit’ I’ll continue for a few more steps anyway, to see what happens.

1 Like

I found this VirtualBox troubleshooting guide:

  • Is the problem specific to a certain guest OS? Or a specific release of a guest OS? Especially with Linux guest related problems, the issue may be specific to a certain distribution and version of Linux.
  • Is the problem specific to a certain host OS? Problems are usually not host OS specific, because most of the Oracle VM VirtualBox code base is shared across all supported platforms, but especially in the areas of networking and USB support, there are significant differences between host platforms. Some GUI related issues are also host specific.
  • Is the problem specific to certain host hardware? This category of issues is typically related to the host CPU. Because of significant differences between VT-x and AMD-V, problems may be specific to one or the other technology. The exact CPU model may also make a difference, even for software virtualization, because different CPUs support different features, which may affect certain aspects of guest CPU operation.
  • Is the problem specific to a certain virtualization mode? Some problems may only occur in software virtualization mode, others may be specific to hardware virtualization.
  • Is the problem specific to guest SMP? That is, is it related to the number of virtual CPUs (VCPUs) in the guest? Using more than one CPU usually significantly affects the internal operation of a guest OS.
  • Is the problem specific to the Guest Additions? In some cases, this is obvious, such as a shared folders problem. In other cases such as display problems, it may be less obvious. If the problem is Guest Additions specific, is it also specific to a certain version of the Guest Additions?
  • Is the problem specific to a certain environment? Some problems are related to a particular environment external to the VM. This usually involves network setup. Certain configurations of external servers such as DHCP or PXE may expose problems which do not occur with other, similar servers.
  • Is the problem a regression? Knowing that an issue is a regression usually makes it significantly easier to find the solution. In this case, it is crucial to know which version is affected and which is not.
1 Like

Great work, deciding to check the VM through the VirtualBox console. I’m on mobile right now, so I can’t properly read the logs. I’ll take a gander ASAP.

No need to dual boot your box by the way. If we can first manage to get VirtualBox to behave with a standard Linux VM, we can then move on to the lab boxes. Would you happen to have a Linux install ISO available, so you can try and spin up a vanilla, new VM?

Your 16GB of RAM should suite wonderfully, as would the i7 processor. So yeah, time to try a plain Linux box first.

1 Like

Hey, thanks for your help, @Tess_Sluijter. I do have on hand Ubuntu 18 LTS, but it is easy enough to grab another if necessary. I will attempt to create a VM based on it when I catch a moment.

Excellent trouble shooting steps so far and I commend you for your patience!

I’m also looking into this issue on my end, hoping we can reach a resolution. Just want you to know we do care about issues like these and it’s never our intention for students to have to go through this process.

1 Like


Ok, I’m noticing an increase in tickets on virtuabox’s support site surrounding this. It seems to be caused when hyper-v is enabled.

Could you try the following (copied from a guide on how to turn off hyper-v)?

  1. Press Windows key.
  2. Type “Turn Windows features on or off”
  3. Deselect checkbox next to Hyper - V .
  4. Select OK.
  5. Select Restart now.

If you’re unable or unwilling to do this, I completely understand, but it will help remove one variable at the least.


To continue a brief update before I get started on my house chores:

I used Vagrant to load up a radically different OS using this Vagrantfile:

Vagrant.configure("2") do |config| = "Microsoft/EdgeOnWindows10"
  config.vm.box_version = "1.0"

Surprisingly (no sarcasm), it was an identical result down to the messages, of hanging while attempting to connect, and VirtualBox becoming unresponsive while the VM is running. I had to kill the process and VirtualBox GUI shows the VM as ‘aborted’ (same as with Ubuntu/trusty64).

So, I’m going to hazard a guess that the ‘guest OS’ is not a factor. It is something to do with VirtualBox itself.

Next (probably tomorrow) I will try @Tess_Sluijter’s suggestion of creating a vanilla VM without Vagrant. My prediction is that it will be the same, but we shall see!

1 Like

Hey thanks, Nathan. I understand completely

Yes, I am totally willing to try your suggestion. I may need to wait to get back to you on this, but will do it by tomorrow at the latest.

1 Like

Silly idea: you do have VT-x enabled in BIOS right? You should, otherwise Vagrant would throw a fit…

1 Like

Just this week we had a thread where a student was setting up Docker, which asks you to ENABLE Hyper-V. The Docker screen actually included a warning that this would indeed break VirtualBox and the likes.

1 Like

The development and operations environments are changing fast and unfortunately it’s hard for us to predict which tooling someone is already using, if any.

The pain is definitely felt!

1 Like

Oh I wasn’t commenting negatively on you guys! Honestly! I was just pointing out what you did: there’s been some more issues recently.

Okay, brief update!

I indeed did have Hyper-V enabled! When I disabled it, two things happened:

  1. Docker squawked, and asked me to turn it on
  2. More importantly, VirtualBox no longer hung when I clicked on the button representing a VM

Sadly, this did not fix the issue, and it still hangs as described originally.

ALSO: I checked to see if ‘VT-x’ was enabled in BIOS. It was. (my BIOS labels it as ‘Virtualization’, but the internet assures me - assures me - that it’s the same thing. So it must be true.) But just in case, since I heard rumblings that the BIOS might have a checkmark but it’s not actually enabled, I disabled it, restarted, and then enabled it again. Sadly, the result is as before.

I will probably be putting on Linux this weekend, to see what I can do.

Correct, that’ll happen. I guess Docker requires Hyper-V functionality. I assume you were using Docker for something else, right? Otherwise you could leave Hyper-V disabled for now.

The problem is: Docker also warns that enabling Hyper-V will break VirtualBox. So it’s either VB or D, but not both.

Yeah… looks like you’re better off dual-booting this box, or running your labs elsewhere.

Hang on! Here’s an idea! Since Hyper-V is enabled… why not just use that to make an Ubuntu VM? @Norberto posted instructions in another thread on how you can convert a standard Ubuntu VM into the M103 lab VM! That should work nicely for you, no?

Here’s Norberto’s post on converting an Ubuntu 14.04 into the M103 VM.

1 Like