Vagrant up with 500 Internal Privoxy Error

I try many times.but I get the same error. but I can access this url by chrome, it don’t have any http 500 error.
mongod-m103: Failed to fetch http://repo.mongodb.com/apt/ubuntu/dists/trusty/mongodb-enterprise/3.6/multiverse/binary-amd64/Packages 500 Internal Privoxy Error
mongod-m103: E

here is the log msg:
E:\m103>vagrant destroy
mongod-m103: Are you sure you want to destroy the ‘mongod-m103’ VM? [y/N] y
==> mongod-m103: Forcing shutdown of VM…
==> mongod-m103: Destroying VM and associated drives…

E:\m103>vagrant up --provision
Bringing machine ‘mongod-m103’ up with ‘virtualbox’ provider…
==> mongod-m103: Importing base box ‘ubuntu/trusty64’…
==> mongod-m103: Matching MAC address for NAT networking…
==> mongod-m103: Setting the name of the VM: mongod-m103
==> mongod-m103: Clearing any previously set forwarded ports…
==> mongod-m103: Clearing any previously set network interfaces…
==> mongod-m103: Preparing network interfaces based on configuration…
mongod-m103: Adapter 1: nat
mongod-m103: Adapter 2: hostonly
==> mongod-m103: Forwarding ports…
mongod-m103: 22 (guest) => 2222 (host) (adapter 1)
==> mongod-m103: Running ‘pre-boot’ VM customizations…
==> mongod-m103: Booting VM…
==> mongod-m103: Waiting for machine to boot. This may take a few minutes…
mongod-m103: SSH address: 127.0.0.1:2222
mongod-m103: SSH username: vagrant
mongod-m103: SSH auth method: private key
mongod-m103: Warning: Connection reset. Retrying…
mongod-m103: Warning: Connection aborted. Retrying…
mongod-m103: Warning: Remote connection disconnect. Retrying…
mongod-m103:
mongod-m103: Vagrant insecure key detected. Vagrant will automatically replace
mongod-m103: this with a newly generated keypair for better security.
mongod-m103:
mongod-m103: Inserting generated public key within guest…
mongod-m103: Removing insecure key from the guest if it’s present…
mongod-m103: Key inserted! Disconnecting and reconnecting using new SSH key…
==> mongod-m103: Machine booted and ready!
==> mongod-m103: Checking for guest additions in VM…
mongod-m103: The guest additions on this VM do not match the installed version of
mongod-m103: VirtualBox! In most cases this is fine, but in rare cases it can
mongod-m103: prevent things such as shared folders from working properly. If you see
mongod-m103: shared folder errors, please make sure the guest additions within the
mongod-m103: virtual machine match the version of VirtualBox you have installed on
mongod-m103: your host and reload your VM.
mongod-m103:
mongod-m103: Guest Additions Version: 4.3.40
mongod-m103: VirtualBox Version: 6.1
==> mongod-m103: Setting hostname…
==> mongod-m103: Configuring and enabling network interfaces…
==> mongod-m103: Configuring proxy for Apt…
==> mongod-m103: Configuring proxy environment variables…
==> mongod-m103: Mounting shared folders…
mongod-m103: /shared => E:/m103/shared
mongod-m103: /vagrant => E:/m103
mongod-m103: /dataset => E:/m103/dataset
==> mongod-m103: Running provisioner: shell…
mongod-m103: Running: C:/Users/foresee/AppData/Local/Temp/vagrant-shell20200223-21240-atdbne
mongod-m103: + config
mongod-m103: + sudo su
mongod-m103: + echo -e never
mongod-m103: + echo -e never
mongod-m103: + sudo tee /etc/init/mongod.override
mongod-m103: + echo manual
mongod-m103: manual
mongod-m103: + ip_config
mongod-m103: ++ ifconfig
mongod-m103: ++ grep -v 127.0.0.1
mongod-m103: ++ grep ‘inet addr:’
mongod-m103: ++ cut -d: -f2
mongod-m103: ++ tail -1
mongod-m103: ++ awk ‘{ print $1}’
mongod-m103: + export CLIENT_IP_ADDR=192.168.103.100
mongod-m103: + CLIENT_IP_ADDR=192.168.103.100
mongod-m103: ++ hostname
mongod-m103: ++ cut -d. -f 1
mongod-m103: ++ tr ‘[:upper:]’ ‘[:lower:]’
mongod-m103: + export CLIENT_NAME=m103
mongod-m103: + CLIENT_NAME=m103
mongod-m103: + echo ‘Configuring /etc/hosts …’
mongod-m103: Configuring /etc/hosts …
mongod-m103: + echo '127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4 ’
mongod-m103: + echo ‘::1 localhost localhost.localdomain localhost6 localhost6.localdomain6’
mongod-m103: + echo ‘fe00::0 ip6-localnet’
mongod-m103: + echo ‘ff00::0 ip6-mcastprefix’
mongod-m103: + echo ‘ff02::1 ip6-allnodes’
mongod-m103: + echo ‘ff02::2 ip6-allrouters’
mongod-m103: + echo ‘ff02::3 ip6-allhosts’
mongod-m103: + echo ‘192.168.103.100 m103’
mongod-m103: Install MongoDB Enterprise Repository
mongod-m103: + update_repo
mongod-m103: + echo ‘Install MongoDB Enterprise Repository’
mongod-m103: + sudo tee /etc/apt/sources.list.d/mongodb-enterprise.list
mongod-m103: + echo ‘deb [ arch=amd64 ] http://repo.mongodb.com/apt/ubuntu trusty/mongodb-enterprise/3.6 multiverse’
mongod-m103: deb [ arch=amd64 ] http://repo.mongodb.com/apt/ubuntu trusty/mongodb-enterprise/3.6 multiverse
mongod-m103: + sudo apt-key adv --keyserver keyserver.ubuntu.com --recv 0C49F3730359A14518585931BC711F9BA15703C6
mongod-m103: Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --homedir /tmp/tmp.SlHfZY2ZuZ --no-auto-check-trustdb --trust-model always --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyring /etc/apt/trusted.gpg.d/ubuntu-advantage-esm-infra-trusty.gpg --keyserver keyserver.ubuntu.com --recv 0C49F3730359A14518585931BC711F9BA15703C6
mongod-m103: gpg:
mongod-m103: requesting key A15703C6 from hkp server keyserver.ubuntu.com
mongod-m103: gpg:
mongod-m103: key A15703C6: public key “MongoDB 3.4 Release Signing Key packaging@mongodb.com” imported
mongod-m103: gpg:
mongod-m103: Total number processed: 1
mongod-m103: gpg:
mongod-m103: imported: 1 (RSA: 1)
mongod-m103: + echo ‘Update Repositories’
mongod-m103: Update Repositories
mongod-m103: + sudo apt-get update -y
mongod-m103: Hit http://security.ubuntu.com trusty-security InRelease
mongod-m103: Ign http://archive.ubuntu.com trusty InRelease
mongod-m103: Get:1 http://security.ubuntu.com trusty-security/main Sources [172 kB]
mongod-m103: Get:2 http://archive.ubuntu.com trusty-updates InRelease [65.9 kB]
mongod-m103: Get:3 https://esm.ubuntu.com trusty-infra-security InRelease
mongod-m103: Get:4 https://esm.ubuntu.com trusty-infra-updates InRelease
mongod-m103: Get:5 https://esm.ubuntu.com trusty-infra-security/main amd64 Packages
mongod-m103: Hit http://archive.ubuntu.com trusty-backports InRelease
mongod-m103: Get:6 http://security.ubuntu.com trusty-security/universe Sources [102 kB]
mongod-m103: Get:7 https://esm.ubuntu.com trusty-infra-security/main Translation-en_US
mongod-m103: Hit http://archive.ubuntu.com trusty Release.gpg
mongod-m103: Get:8 https://esm.ubuntu.com trusty-infra-updates/main Translation-en_US
mongod-m103: Hit http://security.ubuntu.com trusty-security/main amd64 Packages
mongod-m103: Get:9 http://archive.ubuntu.com trusty-updates/main Sources [431 kB]
mongod-m103: Hit http://security.ubuntu.com trusty-security/universe amd64 Packages
mongod-m103: Ign http://repo.mongodb.com trusty/mongodb-enterprise/3.6 InRelease
mongod-m103: Hit http://security.ubuntu.com trusty-security/main Translation-en
mongod-m103: Get:10 http://archive.ubuntu.com trusty-updates/restricted Sources [6,313 B]
mongod-m103: Get:11 http://repo.mongodb.com trusty/mongodb-enterprise/3.6 Release.gpg [801 B]
mongod-m103: Hit http://security.ubuntu.com trusty-security/universe Translation-en
mongod-m103: Get:12 http://archive.ubuntu.com trusty-updates/universe Sources [231 kB]
mongod-m103: Ign http://repo.mongodb.com trusty/mongodb-enterprise/3.6 Release
mongod-m103: Get:13 http://archive.ubuntu.com trusty-updates/multiverse Sources [7,535 B]
mongod-m103: Ign https://esm.ubuntu.com trusty-infra-security/main Translation-en_US
mongod-m103: Ign https://esm.ubuntu.com trusty-infra-security/main Translation-en
mongod-m103: Ign https://esm.ubuntu.com trusty-infra-updates/main Translation-en_US
mongod-m103: Ign https://esm.ubuntu.com trusty-infra-updates/main Translation-en
mongod-m103: Get:14 http://archive.ubuntu.com trusty-updates/main amd64 Packages [1,177 kB]
mongod-m103: Get:15 http://archive.ubuntu.com trusty-updates/restricted amd64 Packages [17.2 kB]
mongod-m103: Get:16 http://archive.ubuntu.com trusty-updates/universe amd64 Packages [525 kB]
mongod-m103: Get:17 http://archive.ubuntu.com trusty-updates/multiverse amd64 Packages [14.6 kB]
mongod-m103: Get:18 http://archive.ubuntu.com trusty-updates/main Translation-en [582 kB]
mongod-m103: Err http://repo.mongodb.com trusty/mongodb-enterprise/3.6/multiverse amd64 Packages
mongod-m103: 500 Internal Privoxy Error
mongod-m103: Ign http://repo.mongodb.com trusty/mongodb-enterprise/3.6/multiverse Translation-en_US
mongod-m103: Get:19 http://archive.ubuntu.com trusty-updates/multiverse Translation-en [7,616 B]
mongod-m103: Get:20 http://archive.ubuntu.com trusty-updates/restricted Translation-en [4,028 B]
mongod-m103: Get:21 http://archive.ubuntu.com trusty-updates/universe Translation-en [281 kB]
mongod-m103: Get:22 http://archive.ubuntu.com trusty-backports/main Sources [9,709 B]
mongod-m103: Ign http://repo.mongodb.com trusty/mongodb-enterprise/3.6/multiverse Translation-en
mongod-m103: Get:23 http://archive.ubuntu.com trusty-backports/universe Sources [35.4 kB]
mongod-m103: Get:24 http://archive.ubuntu.com trusty-backports/multiverse Sources [1,896 B]
mongod-m103: Hit http://archive.ubuntu.com trusty-backports/main amd64 Packages
mongod-m103: Hit http://archive.ubuntu.com trusty-backports/restricted amd64 Packages
mongod-m103: Hit http://archive.ubuntu.com trusty-backports/universe amd64 Packages
mongod-m103: Hit http://archive.ubuntu.com trusty-backports/multiverse amd64 Packages
mongod-m103: Hit http://archive.ubuntu.com trusty-backports/main Translation-en
mongod-m103: Hit http://archive.ubuntu.com trusty-backports/multiverse Translation-en
mongod-m103: Hit http://archive.ubuntu.com trusty-backports/restricted Translation-en
mongod-m103: Hit http://archive.ubuntu.com trusty-backports/universe Translation-en
mongod-m103: Hit http://archive.ubuntu.com trusty Release
mongod-m103: Get:25 http://archive.ubuntu.com trusty-backports/restricted Sources [40 B]
mongod-m103: Get:26 http://archive.ubuntu.com trusty/main Sources [1,064 kB]
mongod-m103: Get:27 http://archive.ubuntu.com trusty/restricted Sources [5,433 B]
mongod-m103: Get:28 http://archive.ubuntu.com trusty/universe Sources [6,399 kB]
mongod-m103: Get:29 http://archive.ubuntu.com trusty/multiverse Sources [174 kB]
mongod-m103: Hit http://archive.ubuntu.com trusty/main amd64 Packages
mongod-m103: Hit http://archive.ubuntu.com trusty/restricted amd64 Packages
mongod-m103: Hit http://archive.ubuntu.com trusty/universe amd64 Packages
mongod-m103: Hit http://archive.ubuntu.com trusty/multiverse amd64 Packages
mongod-m103: Hit http://archive.ubuntu.com trusty/main Translation-en
mongod-m103: Hit http://archive.ubuntu.com trusty/multiverse Translation-en
mongod-m103: Hit http://archive.ubuntu.com trusty/restricted Translation-en
mongod-m103: Hit http://archive.ubuntu.com trusty/universe Translation-en
mongod-m103: Ign http://archive.ubuntu.com trusty/main Translation-en_US
mongod-m103: Ign http://archive.ubuntu.com trusty/multiverse Translation-en_US
mongod-m103: Ign http://archive.ubuntu.com trusty/restricted Translation-en_US
mongod-m103: Ign http://archive.ubuntu.com trusty/universe Translation-en_US
mongod-m103: Fetched 11.6 MB in 1min 7s (172 kB/s)
mongod-m103: W
mongod-m103: :
mongod-m103: Failed to fetch http://repo.mongodb.com/apt/ubuntu/dists/trusty/mongodb-enterprise/3.6/multiverse/binary-amd64/Packages 500 Internal Privoxy Error
mongod-m103: E
mongod-m103: :
mongod-m103: Some index files failed to download. They have been ignored, or old ones used instead.
The SSH command responded with a non-zero exit status. Vagrant
assumes that this means the command failed. The output for this command
should be in the log above. Please read the output to determine what
went wrong.

E:\m103>

There are a couple of potential blockers:

  1. Corporate network using a proxy
  2. Firewall
  3. VPN
1 Like

Also we run vagrant commands from vagrant-env folder
Did you try that?Did it make any difference

Looks to be firewall/nw issues as 007_jb mentioned

1 Like

Because in china and the GFW. I cannot direct access, I am in complex network condition. vagrant ->vargrant proxy-> v2ray client-> v2ray server -> target server. It see all ok to down load vbox image ,update ubuntu repo . exceptive mongo repo read.
I give up apt-get install mongo method , instead of change vagrant script direct download mongo tgz package to install mongo. but keep some ubuntu original package install by apt-get install.
any way, thanks all the answers.

2 Likes

I found other way to solve.
modifiy provision-mongod,disable update_repo install_mongod install_pymongo functions. then vm will work up, and then ssh to vm ,excute the disable function script commands sequence. I will also have some 500 Internal Privoxy Error,but I can try many times as I can.I change some VPN nodes and try, then success.

Hi @David_27990,

Thanks for the update. I really appreciate your efforts :clap: .

Please feel free to get back to us if you need any help in the course.

Thanks,
Shubham Ranjan
Curriculum Services Engineer