Vagrant up --provision problem

Since this is my second time around (couldn’t finish this course last time due to a major problem with the Virtual environment), I was trying to re do everything.

Got a problem with the installation process. I’m on a mackbook pro 10.13.6 (High Sierra).

I got the error saying that the virtual disk already exists. Despite trying to get rid of everything, uninstall everything, vagrant 2.2.5 are glued at my system. When I try to start Virtual box to see if I can get rid of everything. The same error occurs “Cannot register the hard disk, already exists”.

And the funny thing? There is no folder Virtual Box VMs/mongod… on my mac! Not hidden, no existing. But vagrant and Virtual box keeps sending the same error.

Is there a way to erase and delete everything so I could start again from zero?

This is the complete error message:

There was an error while executing VBoxManage, a CLI used by Vagrant
for controlling VirtualBox. The command and stderr is shown below.

Command: [“list”, “hostonlyifs”]

Stderr: VBoxManage: error: Failed to create the VirtualBox object!
VBoxManage: error: Cannot register the hard disk ‘/Users/digger/VirtualBox VMs/mongod-m103/box-disk1.vmdk’ {37b9f479-a2a4-46ec-a080-d91070cf2c69} because a hard disk ‘/Users/digger/VirtualBox VMs/mongod-m103/box-disk1.vmdk’ with UUID {bd16eb51-e1bc-4199-9028-8b76095dda06} already exists
VBoxManage: error: Details: code NS_ERROR_INVALID_ARG (0x80070057), component VirtualBoxWrap, interface IVirtualBox

Did you try vagrant destroy

HELP! Virtualbox Issue

Hi @Diggerfdf,

Please refer to the VirtualBox&Vagrant_MacOS doc in the Handouts section of the Lecture:Setting up the Vagrant Environment to remove Vagrant and start the process from scratch.

Let me know, if you have any questions.