Vagrant up --provision errors abound Windows 10

Everything was running great up until the download_dataset portion of vagrant up --provision

mongod-m103: + curl -s https://s3.amazonaws.com/edu-static.mongodb.com/lessons/M103/products.json.tgz -o products.json.tgz
mongod-m103: + tar -xzvf products.json.tgz -C /dataset
mongod-m103: products.json
mongod-m103:
mongod-m103: gzip: stdin: invalid compressed data--crc error
mongod-m103:
mongod-m103: gzip: stdin: invalid compressed data--length error
mongod-m103: tar: Child returned status 1
mongod-m103: tar: Error is not recoverable: exiting now

Pulled the tarball file to my desktop, and it extracts just fine. Also checked the file creation on the VM, and the file is there. Not sure why the tar call is failing.

I figured I’d try running the rest of the commands manually and just end up with a slew of errors. In short, pretty much nothing runs properly in download_dataset and download_validators.

Seems like this is a full halt on this M103 course for me. Anyone else encountering these issues? This should be a universal issue since it seems like an issue with the VM image itself.

Just re-provisioned this machine and it worked perfectly fine.

It sounds like you re-ran the curl command on your host machine as opposed to copying the file from the VM to your host machine? If that’s the case then it’s possible that the file on the VM is incomplete, empty or corrupt.

Run these tests:

  1. Check if mongod installed:
    mongod --version
  2. Place the tarball file that worked inside the shared folder on your host machine, and run the single tar command from the VM ensuring it’s pointing to the /shared folder:
    tar -xzvf /shared/products.json.tgz -C /dataset
    NB: The shared folder on your host machine is synced to the /shared folder in your VM
1 Like

Must have been a gremlin… Ran vagrant up --provision for the 4th time just now… Unlike the previous 3x, the scripts all ran without fail! :smiley:

and validate_box runs fine.

Looks like mongod is all good too:

db version v3.6.17
git version: 3d6953c361213c5bfab23e51ab274ce592edafe6
OpenSSL version: OpenSSL 1.0.1f 6 Jan 2014
allocator: tcmalloc
modules: enterprise
build environment:
distmod: ubuntu1404
distarch: x86_64
target_arch: x86_64

Hi @Jared_23723,

I’m glad your issue got resolved. Please feel free to get back to us if you have any other query.

Thanks,
Shubham Ranjan
Curriculum Services Engineer