Vagrant up --provision error windows 7 64bit

Hello, everyone.

I’m doing the setup of Vagrant Environment but I get the following message:

vagrant-error1

Can Anybody tell me what does it means?

Thanks in advance
Regards

Hi @jtony2976,

If you have installed the latest version of virtualbox (6.1) and vagrant (2.7) on your system then please uninstall it -> Remove any directories related to virtualbox and vagrant from your system -> download and install the older versions using this link :

VirtualBox 6.0

Vagrant 2.6 (msi package)

Please let me know if the issue still persists.

Thanks,
Shubham Ranjan
Curriculum Services Engineer

Hi Shubham Ranjan.

First, thank you for answering my question.

I did what you told me. I uninstall vagrant and virtual box first then this are the version I install:
image

then I try again: vagrant up --provision but i’m still getting the same error as before:

image

I’ve been reading about this issue and people recommend to enable virtualization option inside the BIOS as a possible solution for this problem. I check my laptop and I do have that option enabled.

What other configuration may I be missing?

Regards.

What happens when you open CMD as a normal user (instead of Administrator) and run it?

vagrant destroy -f
vagrant up

… on a non-Admin terminal

I open CMD as normal user and run the commands but same result:

There’s another course taker experiencing the same odd problem as you. Can you try the steps mentioned in this post.

1 Like

Hi @jtony2976,

Can you please confirm that hyper-V is disabled in your system ?

And also please share the version of your Windows OS.

Thanks,
Shubham Ranjan
Curriculum Services Engineer

Hi Shubham

I’m still getting the same error after doing what it’s said in the post you told me.

Here’s the info of the OS I’m using:

image

And here’s info about virtualization options in the BIOS:

image
image
image
image

This last option can’t be enabled.

Can you share the following:

  1. The name of your Anti Virus
  2. Screenshots of all the software that’s installed? Feel free to scrub off the ones you don’t want to publish.
  3. Screenshots of all the Windows installed updates

Hello, here’s the info about what software and updates I have installed on my laptop.
Software:


Updates:

Antivirus:

Microsoft Essentials
KACE Agent System Tray Utility
IBM Security Trusteer Rapport

Regards

Thanks! Please follow these steps judiciously:

  1. Download VirtualBox 6.0.14. Don’t install it just yet.
  2. Delete the mongod-m103 machine by running:
    vagrant destroy -f
  3. Uninstall VirtualBox
  4. Delete these two folders:
    image
  5. Uninstall Trusteer Endpoint Protection
  6. Reboot
  7. Turn off all anti-virus and malware
  8. Install VirtualBox 6.0.14
  9. Reboot
  10. Turn off all anti-virus, malware and firewall
  11. Run vagrant up and show us the last page of the output

If the above works, turn your antivirus, malware and firewall back on but don’t install Trusteer. Then run the following and make sure you get the same output as step #11:
vagrant destroy -f
vagrant up

NB: I’d suggest that you take a pic of the steps with your phone so that you don’t miss anything