Vagrant up - permission denied

Ran command ‘vagrant halt’ from windows OS, worked fine.
Ran command ‘vagrant up’ from windows OS, got following error:

Bringing machine ‘mongod-m103’ up with ‘virtualbox’ provider…
C:/HashiCorp/Vagrant/embedded/gems/2.1.5/gems/vagrant-2.1.5/plugins/providers/virtualbox/action/set_name.rb:46:in `initialize’: Permission denied @ rb_sysopen

I can start up the M103 VM manually via VirtualBox without any issues.

Hello dheensa,

Try to open your prompt with the right click and then “Execute as administrator”. Maybe it will work…

1 Like

Hi leomarques90
That did not work. Thanks for the advice anyway

Hi dheensa,

Have you tried running from VirtualBox? Steps:

  • Open VirtualBox
  • Select m103 box.
  • Click on Start

Also, check this link, if it can help something. It has some common problems and solutions for Windows.

Let me know if it works!


Hi Kanika. That’s what I have been doing to progress, but not sure why it doesn’t work from vagrant. Not an issue, I can carry on which is the main thing

1 Like